# CVE-2026-42997: OpenStack Ironic has an Incorrect Resource Transfer Between Spheres

> Attackers can obtain sensitive Keystone tokens or basic credentials during import, potentially gaining unauthorized access to OpenStack services.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-42997, GHSA-54w4-233h-x86g, PYSEC-2026-2526, RHSA-2026:39811, UBUNTU-CVE-2026-42997

## What is CVE-2026-42997?

CVE-2026-42997 is a high-severity vulnerability in OpenStack Ironic, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in idrac in OpenStack Ironic before 35.0.1. During import, a user invoking molds can request authorization to be sent to a remote endpoint. The credential forwarded is a time-limited Keystone token (which provides access to all OpenStack services Ironic is authorized for); or basic credentials configured for molds storage. The fixed versions are 26.1.6, 29.0.5, 32.0.1, and 35.0.1.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2026-42997?

9 open source packages ship an affected version, including ironic-python-agent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ironic-python-agent` | PyPI | All versions | 26.1.6, 29.0.5, 32.0.1, 35.0.1 |
| `ironic-python-agent` | PyPI | All versions | 26.1.6 |
| `ironic-python-agent` | PyPI | All versions | 26.1.6 |
| `ironic-python-agent` | PyPI | From 27.0.0 | 29.0.5 |
| `ironic-python-agent` | PyPI | From 27.0.0 | 29.0.5 |
| `ironic-python-agent` | PyPI | From 30.0.0 | 32.0.1 |
| `ironic-python-agent` | PyPI | From 30.0.0 | 32.0.1 |
| `ironic-python-agent` | PyPI | From 33.0.0 | 35.0.1 |
| `ironic-python-agent` | PyPI | From 33.0.0 | 35.0.1 |
| `openstack-ironic` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20260616204937.9213ccd.el9ost |
| `openstack-ironic-api` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20260616204937.9213ccd.el9ost |
| `openstack-ironic-common` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20260616204937.9213ccd.el9ost |
| `openstack-ironic-conductor` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20260616204937.9213ccd.el9ost |

Products: Openstack Ironic.

## How do I fix CVE-2026-42997?

Upgrade ironic-python-agent to a fixed version for your release line: 26.1.6, 29.0.5, 32.0.1 or 35.0.1.

## Is CVE-2026-42997 being exploited?

There is no known exploitation of CVE-2026-42997 in the wild and no public exploit code.

## Other vulnerabilities in OpenStack Ironic

- [CVE-2026-42510](https://insights.sbomify.com/CVE-2026-42510/): OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere (medium 6.6)
- [CVE-2015-7514](https://insights.sbomify.com/CVE-2015-7514/): Information disclosure in n/a (medium 6.5)
- [CVE-2026-48681](https://insights.sbomify.com/CVE-2026-48681/): OpenStack Ironic allows file overwrite via directory traversal during deployment with a crafted ISO image (medium 5.9)
- [CVE-2026-46447](https://insights.sbomify.com/CVE-2026-46447/): OpenStack Ironic allows Boot Script Injection (medium 5.8)
- [CVE-2026-50589](https://insights.sbomify.com/CVE-2026-50589/): OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42997 and fix it if it is affected.

What it is: CVE-2026-42997 is a high-severity vulnerability in OpenStack Ironic, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42997 in the wild and no public exploit code.

Affected packages and fixed versions:
- ironic-python-agent (PyPI): affected all versions; fixed in 26.1.6, 29.0.5, 32.0.1, 35.0.1
- ironic-python-agent (PyPI): affected all versions; fixed in 26.1.6
- ironic-python-agent (PyPI): affected all versions; fixed in 26.1.6
- ironic-python-agent (PyPI): affected from 27.0.0; fixed in 29.0.5
- ironic-python-agent (PyPI): affected from 27.0.0; fixed in 29.0.5
- ironic-python-agent (PyPI): affected from 30.0.0; fixed in 32.0.1
- ironic-python-agent (PyPI): affected from 30.0.0; fixed in 32.0.1
- ironic-python-agent (PyPI): affected from 33.0.0; fixed in 35.0.1
- ironic-python-agent (PyPI): affected from 33.0.0; fixed in 35.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42997/ (Markdown: https://insights.sbomify.com/CVE-2026-42997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42997
- OSV: https://osv.dev/vulnerability/CVE-2026-42997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42997/
Summaries are generated and may contain mistakes; the official description above is the record.
