# CVE-2026-42998: OpenStack Keystone doesn't verify that the user supplied in the authentication request matches the owner of the application credential

> Attackers can impersonate other users by mismatching application credential owners, enabling audit evasion and unauthorized access in OpenStack Keystone.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 28 May 2026
- **Also known as:** DEBIAN-CVE-2026-42998, GHSA-8f8m-wrvr-wcvf, PYSEC-2026-599

## What is CVE-2026-42998?

CVE-2026-42998 is a medium-severity authentication bypass vulnerability in OpenStack Keystone, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in OpenStack Keystone before 29.0.2. The Keystone application credential authentication plugin does not verify that the user supplied in the authentication request matches the owner of the application credential. An attacker can authenticate with their own application credential ID and secret while specifying a different user's name and domain in the request body. Keystone issues a token attributed to the victim user. The impersonated token is project-scoped and carries the intersection of the application credential's roles and the victim's actual roles on the project. This enables audit evasion, reading the victim's credentials, and acting as the victim within shared projects.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-42998?

7 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | From 14.0.0 | 27.0.2, 28.0.2, 29.0.2 |
| `keystone` | PyPI | From 14.0.0 | 27.0.2 |
| `keystone` | PyPI | From 14.0.0 | 27.0.2 |
| `keystone` | PyPI | From 28.0.0 | 28.0.2 |
| `keystone` | PyPI | From 28.0.0 | 28.0.2 |
| `keystone` | PyPI | From 29.0.0 | 29.0.2 |
| `keystone` | PyPI | From 29.0.0 | 29.0.2 |

Products: Openstack Keystone.

## How do I fix CVE-2026-42998?

Upgrade keystone to a fixed version for your release line: 27.0.2, 28.0.2 or 29.0.2.

## Is CVE-2026-42998 being exploited?

There is no known exploitation of CVE-2026-42998 in the wild and no public exploit code.

## Other vulnerabilities in OpenStack Keystone

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42998 and fix it if it is affected.

What it is: CVE-2026-42998 is a medium-severity authentication bypass vulnerability in OpenStack Keystone, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42998 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected from 14.0.0; fixed in 27.0.2, 28.0.2, 29.0.2
- keystone (PyPI): affected from 14.0.0; fixed in 27.0.2
- keystone (PyPI): affected from 14.0.0; fixed in 27.0.2
- keystone (PyPI): affected from 28.0.0; fixed in 28.0.2
- keystone (PyPI): affected from 28.0.0; fixed in 28.0.2
- keystone (PyPI): affected from 29.0.0; fixed in 29.0.2
- keystone (PyPI): affected from 29.0.0; fixed in 29.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42998/ (Markdown: https://insights.sbomify.com/CVE-2026-42998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42998
- OSV: https://osv.dev/vulnerability/CVE-2026-42998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42998/
Summaries are generated and may contain mistakes; the official description above is the record.
