# CVE-2026-43001: OpenStack Keystone has an Incorrect Authorization Issue

> Attackers with application credentials can create EC2 credentials for other projects, enabling cross-project lateral movement and unauthorized token issuance.

- **Severity:** High 7.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2026
- **Updated:** 14 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-43001, GHSA-hhq2-3832-xxcv, PYSEC-2026-602

## What is CVE-2026-43001?

CVE-2026-43001 is a high-severity missing authorization vulnerability in OpenStack Keystone, published on 1 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue was discovered in OpenStack Keystone before 29.0.2. POST /v3/credentials did not validate that the caller-supplied project_id for an EC2-type credential matched the project of the authenticating application credential. This allowed an attacker holding an unrestricted application credential for project A to create an EC2 credential targeting project B; a subsequent /v3/ec2tokens exchange would then issue a Keystone token scoped to project B while still carrying the original app_cred_id, enabling cross-project lateral movement within the credential owner's role footprint.

Weakness: CWE-1288 (Improper Validation of Consistency within Input), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-43001?

3 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | From 13.0.0 to 29.0.1 | None |
| `keystone` | PyPI | From 13.0.0 to 29.0.1 | None |
| `keystone` | PyPI | From 14.0.0 | 27.0.2, 28.0.2, 29.0.2 |

Products: Openstack Keystone.

## How do I fix CVE-2026-43001?

Upgrade keystone to a fixed version for your release line: 27.0.2, 28.0.2 or 29.0.2.

## Is CVE-2026-43001 being exploited?

There is no known exploitation of CVE-2026-43001 in the wild and no public exploit code.

## Other vulnerabilities in OpenStack Keystone

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)
- [CVE-2015-7546](https://insights.sbomify.com/CVE-2015-7546/): OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43001 and fix it if it is affected.

What it is: CVE-2026-43001 is a high-severity missing authorization vulnerability in OpenStack Keystone, published on 1 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43001 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected from 13.0.0 up to 29.0.1; no fix listed
- keystone (PyPI): affected from 13.0.0 up to 29.0.1; no fix listed
- keystone (PyPI): affected from 14.0.0; fixed in 27.0.2, 28.0.2, 29.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43001/ (Markdown: https://insights.sbomify.com/CVE-2026-43001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43001
- OSV: https://osv.dev/vulnerability/CVE-2026-43001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43001/
Summaries are generated and may contain mistakes; the official description above is the record.
