# CVE-2026-43003: OpenStack Ironic Python Agent Includes Functionality from Untrusted Control Sphere

> Attackers can execute arbitrary code by providing a malicious partition image to OpenStack Ironic Python Agent during deployment.

- **Severity:** High 8.0 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2026
- **Updated:** 9 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-43003, GHSA-rmxr-45gj-889w, PYSEC-2026-205, UBUNTU-CVE-2026-43003

## What is CVE-2026-43003?

CVE-2026-43003 is a high-severity command injection vulnerability in OpenStack ironic-python-agent, published on 1 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in OpenStack ironic-python-agent 1.0.0 through 11.5.0. Ironic Python Agent (IPA) sometimes executes grub-install from within a chroot of the deployed partition image, leading to code execution in the case of a malicious image.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-43003?

3 open source packages ship an affected version, including ironic-python-agent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ironic-python-agent` | PyPI | From 1.0.0 | 11.6.0 |
| `ironic-python-agent` | PyPI | From 1.0.0 | 11.6.0 |
| `ironic-python-agent` | PyPI | From 1.0.0 | 11.6.0 |

Products: Openstack Ironic Python Agent.

## How do I fix CVE-2026-43003?

Upgrade ironic-python-agent to 11.6.0 or later.

## Is CVE-2026-43003 being exploited?

There is no known exploitation of CVE-2026-43003 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43003 and fix it if it is affected.

What it is: CVE-2026-43003 is a high-severity command injection vulnerability in OpenStack ironic-python-agent, published on 1 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43003 in the wild and no public exploit code.

Affected packages and fixed versions:
- ironic-python-agent (PyPI): affected from 1.0.0; fixed in 11.6.0
- ironic-python-agent (PyPI): affected from 1.0.0; fixed in 11.6.0
- ironic-python-agent (PyPI): affected from 1.0.0; fixed in 11.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43003/ (Markdown: https://insights.sbomify.com/CVE-2026-43003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43003
- OSV: https://osv.dev/vulnerability/CVE-2026-43003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43003/
Summaries are generated and may contain mistakes; the official description above is the record.
