# CVE-2026-4324: Rubygem-katello: katello: denial of service and potential information disclosure via sql injection

> Remote attackers can inject SQL via the bootc_images API to cause denial of service or extract sensitive database information in Red Hat Satellite.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-fwj4-6wgp-mpxm

## What is CVE-2026-4324?

CVE-2026-4324 is a medium-severity SQL injection vulnerability in Red Hat Satellite 6, published on 17 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in the Katello plugin for Red Hat Satellite. This vulnerability, caused by improper sanitization of user-provided input, allows a remote attacker to inject arbitrary SQL commands into the sort_by parameter of the /api/hosts/bootc_images API endpoint. This can lead to a Denial of Service (DoS) by triggering database errors, and potentially enable Boolean-based Blind SQL injection, which could allow an attacker to extract sensitive information from the database.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-4324?

2 open source packages ship an affected version, including katello.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katello` | RubyGems | All versions | 4.19.1 |
| `katello` | RubyGems | All versions | 4.19.1 |

## How do I fix CVE-2026-4324?

Upgrade katello to 4.19.1 or later.

## Is CVE-2026-4324 being exploited?

There is no known exploitation of CVE-2026-4324 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4324 and fix it if it is affected.

What it is: CVE-2026-4324 is a medium-severity SQL injection vulnerability in Red Hat Satellite 6, published on 17 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4324 in the wild and no public exploit code.

Affected packages and fixed versions:
- katello (RubyGems): affected all versions; fixed in 4.19.1
- katello (RubyGems): affected all versions; fixed in 4.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4324/ (Markdown: https://insights.sbomify.com/CVE-2026-4324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4324
- OSV: https://osv.dev/vulnerability/CVE-2026-4324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4324/
Summaries are generated and may contain mistakes; the official description above is the record.
