CVE-2026-43515 Apache Tomcat: Security constraints not correctly applied
Attackers can bypass security constraints in Apache Tomcat when multiple method constraints define an HTTP method for the same extension.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-43515?
CVE-2026-43515 is a critical missing authorization vulnerability in Apache Tomcat, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
Weakness: CWE-285
Which versions are affected by CVE-2026-43515?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | All versions | 9.0.118 |
org.apache.tomcat.embed:tomcat-embed-core Maven | All versions | 9.0.118 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.22 |
13 more packages
tomcat Bitnami | From 10.0.0 | 10.1.55, 11.0.22, 9.0.118 |
org.apache.tomcat:tomcat Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat-catalina Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat-catalina Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.22 |
Products include Apache Tomcat.
How do I fix CVE-2026-43515?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 9.0.118, 10.1.55 or 11.0.22.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-43515 being exploited?
There is no known exploitation of CVE-2026-43515 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-43515, CLEANSTART-2026-SE01248, CLEANSTART-2026-SP62177, CLSA-2026-1781744133, DEBIAN-CVE-2026-43515, GHSA-5m62-pw8w-7w9f and 5 more.