CVE-2026-43531 OpenClaw < 2026.4.9 - Environment Variable Injection via Workspace .env File
Attackers can inject environment variables via workspace files to compromise application behavior, including update sources and executable paths.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-43531?
CVE-2026-43531 is a high-severity vulnerability in Openclaw Openclaw, published on 5 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
OpenClaw before 2026.4.9 contains an environment variable injection vulnerability allowing malicious workspace .env files to set runtime-control variables. Attackers can inject variables affecting update sources, gateway URLs, ClawHub resolution, and browser executable paths to compromise application behavior.
Weakness: CWE-15
Which versions are affected by CVE-2026-43531?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.4.9 |
openclaw npm | All versions | 2026.4.9 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-43531?
Upgrade openclaw to 2026.4.9 or later.
Is CVE-2026-43531 being exploited?
There is no known exploitation of CVE-2026-43531 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-7wv4-cc7p-jhxc, MINI-qww4-mm6h-vr33.