CVE-2026-43571 OpenClaw < 2026.4.10 - Untrusted Workspace Plugin Shadow Resolution in Channel Setup
Attackers can bypass trust gates during channel setup by crafting malicious workspace plugins, potentially leading to unauthorized code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-43571?
CVE-2026-43571 is a high-severity vulnerability in Openclaw Openclaw, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.4.10 contains a plugin trust bypass vulnerability that allows channel setup catalog lookups to resolve workspace plugin shadows before bundled channel plugins. Attackers can exploit this by crafting malicious workspace plugins that bypass intended trust gates during setup-time plugin loading.
Weakness: CWE-829
Which versions are affected by CVE-2026-43571?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.4.10 |
openclaw npm | All versions | 2026.4.10 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-43571?
Upgrade openclaw to 2026.4.10 or later.
Is CVE-2026-43571 being exploited?
There is no known exploitation of CVE-2026-43571 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-82qx-6vj7-p8m2, MINI-x35c-cq9q-hgqm.