CVE-2026-4363 Incorrect Authorization in GitLab

Low 3.7 Published Updated

Authenticated users can gain unauthorized access to resources due to improper caching of authorization decisions in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-4363?

CVE-2026-4363 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 25 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.1 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that under certain conditions could have allowed an authenticated user to gain unauthorized access to resources due to improper caching of authorization decisions.

Weakness: CWE-863

Which versions are affected by CVE-2026-4363?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.1.018.8.7, 18.9.3, 18.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-4363?

Upgrade gitlab to a fixed version for your release line: 18.8.7, 18.9.3 or 18.10.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-4363 being exploited?

There is no known exploitation of CVE-2026-4363 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-4363, GHSA-c3cq-wgrq-qm9r.

Is CVE-2026-4363 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free