CVE-2026-43646 Apache Wicket: crafted URLs can bypass PackageResourceGuard

High 7.5 Published Updated

Attackers can bypass resource guards to access sensitive information in applications using the Apache Wicket framework.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-43646?

CVE-2026-43646 is a high-severity vulnerability in Apache Wicket, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Weakness: CWE-200

Which versions are affected by CVE-2026-43646?

6 open source packages ship an affected version, including org.apache.wicket:wicket-parent. It affects 1 product.

PackageAffectedFixed in
org.apache.wicket:wicket-parent MavenFrom 10.0.0-M110.9.0
org.apache.wicket:wicket-parent MavenFrom 10.0.0-M110.9.0
org.apache.wicket:wicket-parent MavenFrom 8.0.0-M1 to 8.17.0None
org.apache.wicket:wicket-parent MavenFrom 8.0.0-M1 to 8.17.0None
org.apache.wicket:wicket-parent MavenFrom 9.0.0-M1 to 9.22.0None
org.apache.wicket:wicket-parent MavenFrom 9.0.0-M1 to 9.22.0None

Products include Apache Wicket.

How do I fix CVE-2026-43646?

Upgrade org.apache.wicket:wicket-parent to 10.9.0 or later.

Is CVE-2026-43646 being exploited?

There is no known exploitation of CVE-2026-43646 in the wild and no public exploit code.

Sources

Also known as GHSA-jvv4-8wxx-m5r6.

Is CVE-2026-43646 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free