# CVE-2026-4372: Arbitrary Remote Code Execution via `_attn_implementation_internal` Config Injection in huggingface/transformers

> Attackers can execute arbitrary code by crafting a malicious config file that bypasses security checks when loading models in the HuggingFace transformers library.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2026
- **Updated:** 26 May 2026
- **Also known as:** CLSA-2026-1783386115, ECHO-f851-2f9e-9461, GHSA-29pf-2h5f-8g72, PYSEC-2026-2289

## What is CVE-2026-4372?

CVE-2026-4372 is a high-severity unsafe deserialization vulnerability in huggingface/transformers, published on 24 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A critical remote code execution vulnerability exists in all versions of the HuggingFace transformers library prior to version 5.3.0. The vulnerability allows an attacker to craft a malicious `config.json` file containing the `_attn_implementation_internal` field set to an attacker-controlled HuggingFace Hub repository ID. When a victim loads this model using the standard `AutoModelForCausalLM.from_pretrained()` API, the library downloads and executes arbitrary Python code from the attacker's repository with the victim's full OS privileges. This issue arises due to unfiltered deserialization of configuration attributes, insufficient sanitization of internal fields, and unsandboxed execution of downloaded kernels. The vulnerability bypasses the `trust_remote_code` security mechanism, is invisible to the victim, and exploits the standard documented usage pattern, making it particularly severe. Users are advised to upgrade to version 5.3.0 or later to mitigate this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-1066 (Missing Serialization Control Element)

## Which versions are affected by CVE-2026-4372?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 5.3.0 |
| `transformers` | PyPI | All versions | 5.3.0 |
| `transformers` | PyPI | All versions | 5.3.0 |

Products: Huggingface Transformers.

## How do I fix CVE-2026-4372?

Upgrade transformers to 5.3.0 or later.

## Is CVE-2026-4372 being exploited?

There is no known exploitation of CVE-2026-4372 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-4372: Threat Model, Root-Cause Analysis, Replication & Detection (github_poc): https://github.com/alvin21mfmlai/SE6013_Project

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4372 and fix it if it is affected.

What it is: CVE-2026-4372 is a high-severity unsafe deserialization vulnerability in huggingface/transformers, published on 24 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-4372 in the wild and no public exploit code.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 5.3.0
- transformers (PyPI): affected all versions; fixed in 5.3.0
- transformers (PyPI): affected all versions; fixed in 5.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4372/ (Markdown: https://insights.sbomify.com/CVE-2026-4372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4372
- OSV: https://osv.dev/vulnerability/CVE-2026-4372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4372/
Summaries are generated and may contain mistakes; the official description above is the record.
