# CVE-2026-43868: Apache Thrift: Rust implementation vulnerable to CVE-2020-13949 pattern


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 22 Jul 2026
- **Also known as:** BIT-thrift-2026-43868, DEBIAN-CVE-2026-43868, GHSA-2f9f-gq7v-9h6m, UBUNTU-CVE-2026-43868

## What is CVE-2026-43868?

CVE-2026-43868 is a medium-severity vulnerability in Apache Thrift, published on 5 May 2026. 

### Official description

Memory Allocation with Excessive Size Value vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Weakness: CWE-1285 (Improper Validation of Specified Index, Position, or Offset in Input), CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-43868?

3 open source packages ship an affected version, including thrift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.23.0 |
| `thrift` | crates.io | All versions | 0.23.0 |
| `thrift` | crates.io | All versions | 0.23.0 |

Products: Apache Thrift.

## How do I fix CVE-2026-43868?

Upgrade thrift to 0.23.0 or later.

## Is CVE-2026-43868 being exploited?

There is no known exploitation of CVE-2026-43868 in the wild and no public exploit code.

## Other vulnerabilities in Apache Thrift

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43868 and fix it if it is affected.

What it is: CVE-2026-43868 is a medium-severity vulnerability in Apache Thrift, published on 5 May 2026. 
Exploitation: There is no known exploitation of CVE-2026-43868 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.23.0
- thrift (crates.io): affected all versions; fixed in 0.23.0
- thrift (crates.io): affected all versions; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43868/ (Markdown: https://insights.sbomify.com/CVE-2026-43868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43868
- OSV: https://osv.dev/vulnerability/CVE-2026-43868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43868/
Summaries are generated and may contain mistakes; the official description above is the record.
