CVE-2026-43870 Apache Thrift: Node.js web_server.js multi-vulnerability

High 7.3 Published Updated

Attackers can exploit path traversal, HTTP splitting, and resource exhaustion in the Node.js web server component of Apache Thrift.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-43870?

CVE-2026-43870 is a high-severity path traversal vulnerability in Apache Thrift, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Weakness: CWE-400, CWE-346, CWE-22, CWE-113

Which versions are affected by CVE-2026-43870?

3 open source packages ship an affected version, including thrift. It affects 1 product.

PackageAffectedFixed in
thrift BitnamiAll versions0.23.0
thrift npmAll versions to 0.22.0None
thrift npmAll versions to 0.22.0None

Products include Apache Thrift.

How do I fix CVE-2026-43870?

Upgrade thrift to 0.23.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-43870 being exploited?

There is no known exploitation of CVE-2026-43870 in the wild and no public exploit code.

Sources

Also known as BIT-thrift-2026-43870, DEBIAN-CVE-2026-43870, GHSA-526f-jxpj-jmg2, MINI-2m7h-pvrx-x847, MINI-9xf9-jx38-6vjg, MINI-rx7f-g837-9vg8 and 1 more.

Is CVE-2026-43870 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free