# CVE-2026-43871: Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit

> An infinite loop in Apache Thrift bindings allows attackers to cause a denial of service via crafted varint byte counts.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** AZL-93995, AZL-94163, AZL-94220, AZL-94235, AZL-94320, AZL-94329, BIT-thrift-2026-43871, CLEANSTART-2026-AP36720, CLEANSTART-2026-BM76577, CLEANSTART-2026-GN57450, CLEANSTART-2026-IT04262, CLEANSTART-2026-MY58783, CLEANSTART-2026-YY80093, DEBIAN-CVE-2026-43871, ECHO-7f9d-9d60-d057, GHSA-8wv5-x4w7-5gww, MINI-2f82-2hmm-g57p, MINI-2gch-pgw7-5gjf, MINI-2h6v-v674-qrgp, MINI-2hxr-v9w4-wfcg, MINI-2pvc-v9qc-pvv6, MINI-37vw-w35x-w693, MINI-3h8c-7c6q-7269, MINI-3m69-53p9-fwg2, MINI-3w88-3244-xfcv, MINI-45wp-x46g-m647, MINI-494j-gx8c-fq42, MINI-4qfg-fphq-2w9x, MINI-4vf3-66hh-v4h6, MINI-588v-q2h5-w9rx, MINI-5qv5-fxmh-8mjx, MINI-5v82-v86h-85r6, MINI-6248-3xqw-7h27, MINI-62gq-xwj3-g3wr, MINI-749h-3vm2-xmfh, MINI-77w6-m9ff-f83r, MINI-7wfm-7rxr-278q, MINI-877j-59c8-v5rm, MINI-87jm-293w-h75p, MINI-8mrw-h93w-r7q9, MINI-8wq8-p5fx-gqx2, MINI-92g3-2hqv-xc3x, MINI-9p8g-c8g3-v5f6, MINI-c448-xrx7-m928, MINI-cg5j-9wmr-fhrv, MINI-cg8j-xw63-2vhp, MINI-f5qh-m395-f6h5, MINI-f6qc-h34r-6m3x, MINI-f7jh-68fh-p5fq, MINI-fmrm-f2f2-fq4j, MINI-fprj-8hcm-fvq4, MINI-frfq-cr2j-phf2, MINI-fx4m-7h5f-2q9c, MINI-g6g4-999m-w95f, MINI-g8r5-6c49-vhm3, MINI-gmcr-h9rj-mcm2, MINI-h2hq-mrg3-876w, MINI-h58g-gcv4-x84h, MINI-h5x9-qh95-4qv3, MINI-h625-cjmp-vvhr, MINI-hffh-j49r-jr9r, MINI-j67x-cjf9-53f8, MINI-j748-7v4q-497r, MINI-j83g-fm2f-gq7m, MINI-j8hr-w43j-jfmr, MINI-jf7j-4m2c-6hg6, MINI-jxmp-cwx3-4cfh, MINI-m22j-5hrp-v39p, MINI-m22j-86hj-8m2c, MINI-m4vq-vf75-3rmw, MINI-mmrv-hf63-hv9v, MINI-p37g-p9qj-8765, MINI-p39g-882h-4226, MINI-p48v-p5qg-4w4j, MINI-p9qw-47pc-vv8h, MINI-p9vj-fmhp-37rc, MINI-p9vm-98hh-qj86, MINI-pf98-x2fq-jrhx, MINI-pgv4-pqhj-pqgq, MINI-pp2r-82qc-mwhv, MINI-ppm5-j527-924q, MINI-q8fq-6g2v-3mfg, MINI-q992-292m-vhj5, MINI-r2vj-x6mw-6wc5, MINI-r87x-hcqx-v65p, MINI-r94h-r3ph-cpmw, MINI-r99p-6527-669p, MINI-rqfr-3x36-j8w3, MINI-rrhp-99x6-h7hp, MINI-rxxp-25j7-5vvc, MINI-v268-q5jj-hvp2, MINI-v4jv-p27g-m56r, MINI-v633-7239-c3fc, MINI-v66m-v89f-6wpr, MINI-vp6r-vcpg-3vm2, MINI-vp7w-3jfq-q4q2, MINI-vw2c-4grf-vj8x, MINI-w64h-973j-mj8j, MINI-w993-rrvw-87j9, MINI-wr52-3935-5wp6, MINI-ww89-wwfc-3ghq, MINI-wx4h-3fxh-942w, MINI-x248-g675-v898, MINI-x24h-96px-wgrc, MINI-x98p-mxv4-968p, MINI-xv3f-g94r-57x7, PYSEC-2026-3926, ROOT-APP-GOBINARY-CVE-2026-43871, ROOT-APP-MAVEN-CVE-2026-43871, ROOT-APP-PYPI-CVE-2026-43871, UBUNTU-CVE-2026-43871

## What is CVE-2026-43871?

CVE-2026-43871 is a high-severity denial of service vulnerability in Apache Thrift, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-43871?

10 open source packages ship an affected version, including github.com/apache/thrift, thrift and org.apache.thrift:libthrift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/thrift` | Go | All versions | 0.24.0 |
| `github.com/apache/thrift` | Go | All versions | 0.24.0 |
| `thrift` | Bitnami | All versions | 0.24.0 |
| `org.apache.thrift:libthrift` | Maven | All versions | 0.24.0 |
| `org.apache.thrift:libthrift` | Maven | All versions | 0.24.0 |
| `apache/thrift` | Packagist | All versions | 0.24.0 |
| `apache/thrift` | Packagist | All versions | 0.24.0 |
| `thrift` | PyPI | All versions | 0.24.0 |
| `thrift` | PyPI | All versions | 0.24.0 |
| `thrift` | PyPI | All versions | 0.24.0 |

Products: Apache Thrift.

## How do I fix CVE-2026-43871?

Upgrade github.com/apache/thrift to 0.24.0 or later.

## Is CVE-2026-43871 being exploited?

There is no known exploitation of CVE-2026-43871 in the wild and no public exploit code.

## Other vulnerabilities in Apache Thrift

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)
- [CVE-2026-55968](https://insights.sbomify.com/CVE-2026-55968/): Apache Thrift: Node.js quadratic-time DoS in server receive transports (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43871 and fix it if it is affected.

What it is: CVE-2026-43871 is a high-severity denial of service vulnerability in Apache Thrift, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43871 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/thrift (Go): affected all versions; fixed in 0.24.0
- github.com/apache/thrift (Go): affected all versions; fixed in 0.24.0
- thrift (Bitnami): affected all versions; fixed in 0.24.0
- org.apache.thrift:libthrift (Maven): affected all versions; fixed in 0.24.0
- org.apache.thrift:libthrift (Maven): affected all versions; fixed in 0.24.0
- apache/thrift (Packagist): affected all versions; fixed in 0.24.0
- apache/thrift (Packagist): affected all versions; fixed in 0.24.0
- thrift (PyPI): affected all versions; fixed in 0.24.0
- thrift (PyPI): affected all versions; fixed in 0.24.0
- thrift (PyPI): affected all versions; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43871/ (Markdown: https://insights.sbomify.com/CVE-2026-43871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43871
- OSV: https://osv.dev/vulnerability/CVE-2026-43871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43871/
Summaries are generated and may contain mistakes; the official description above is the record.
