# CVE-2026-43899: Code injection in deepchat

> Attackers can execute arbitrary code by bypassing URL validation in native window handlers via malicious Markdown links in DeepChat.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-cp8j-jx7q-7r5f

## What is CVE-2026-43899?

CVE-2026-43899 is a critical code injection vulnerability in ThinkInAIXYZ deepchat, published on 11 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DeepChat is an open-source artificial intelligence agent platform that unifies models, tools, and agents. Prior to v1.0.4-beta.1, An incomplete mitigation for CVE-2025-55733 leaves DeepChat vulnerable to an arbitrary protocol execution bypass (RCE). While the patch correctly restricted api.openExternal() inside the renderer's preload/index.ts script, it structurally neglected to sanitize native Electron pop-up window handlers. An attacker or a compromised AI endpoint returning a Markdown link can trigger a target="_blank" native window interception in tabPresenter.ts, which forwards the malicious URL directly to shell.openExternal(url) and completely bypasses the isValidExternalUrl security boundary. This vulnerability is fixed in v1.0.4-beta.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-43899?


## How do I fix CVE-2026-43899?

No fix has been published for CVE-2026-43899 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-43899 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43899 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43899 and fix it if it is affected.

What it is: CVE-2026-43899 is a critical code injection vulnerability in ThinkInAIXYZ deepchat, published on 11 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43899 exists.

Affected product: ThinkInAIXYZ deepchat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43899/ (Markdown: https://insights.sbomify.com/CVE-2026-43899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43899
- OSV: https://osv.dev/vulnerability/CVE-2026-43899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43899/
Summaries are generated and may contain mistakes; the official description above is the record.
