# CVE-2026-43916: pam_authnft: Heap buffer overflow in NETLINK_SOCK_DIAG reply walker

> A heap buffer over-read in pam_authnft allows attackers to cause denial of service or disclose memory via crafted NETLINK_SOCK_DIAG replies.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-5jj5-hm34-78vh

## What is CVE-2026-43916?

CVE-2026-43916 is a high-severity memory corruption vulnerability in identd-ng pam_authnft, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pam_authnft is a PAM session module binding nftables firewall rules to authenticated sessions via cgroupv2 inodes. Prior to 0.2.0-alpha, a heap buffer over-read in peer_lookup_tcp (src/peer_lookup.c:134, prior to the fix) allowed a crafted NETLINK_SOCK_DIAG reply to slip past the message-size check, then dereference past the end of the allocation. This vulnerability is fixed in 0.2.0-alpha.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound)), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-43916?


## How do I fix CVE-2026-43916?

No fix has been published for CVE-2026-43916 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-43916 being exploited?

There is no known exploitation of CVE-2026-43916 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43916 and fix it if it is affected.

What it is: CVE-2026-43916 is a high-severity memory corruption vulnerability in identd-ng pam_authnft, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43916 in the wild and no public exploit code.

Affected product: identd-ng pam_authnft. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43916/ (Markdown: https://insights.sbomify.com/CVE-2026-43916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43916
- OSV: https://osv.dev/vulnerability/CVE-2026-43916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43916/
Summaries are generated and may contain mistakes; the official description above is the record.
