# CVE-2026-43935: e107: Host Header Injection in e107 password reset enables phishing

> Attackers can manipulate Host headers in password reset emails to redirect users to malicious sites, enabling phishing and account takeover.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-7pmw-jwvr-cq2x

## What is CVE-2026-43935?

CVE-2026-43935 is a high-severity vulnerability in e107inc e107, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

e107 is a content management system (CMS). Prior to 2.3.4, a Host Header Injection vulnerability in the password reset page allows attackers to manipulate the Host header to generate password reset links pointing to attacker-controlled domains. This can lead to phishing attacks, account takeover, or other security risks. The severity is high, as the vulnerability affects a critical function related to user authentication. This vulnerability is fixed in 2.3.4.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-43935?


## How do I fix CVE-2026-43935?

No fix has been published for CVE-2026-43935 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-43935 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43935 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43935 and fix it if it is affected.

What it is: CVE-2026-43935 is a high-severity vulnerability in e107inc e107, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43935 exists.

Affected product: e107inc e107. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43935/ (Markdown: https://insights.sbomify.com/CVE-2026-43935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43935
- OSV: https://osv.dev/vulnerability/CVE-2026-43935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43935/
Summaries are generated and may contain mistakes; the official description above is the record.
