# CVE-2026-43937: YAF.NET: Pre-Handler Authorization Bypass on Admin Pages Enabling Blind SQL Execution via `/Admin/RunSql`

> Low-privileged users can bypass authorization checks to execute arbitrary SQL commands via the admin RunSql endpoint in YAF.NET forums.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-xhw7-j96h-c3g5

## What is CVE-2026-43937?

CVE-2026-43937 is a high-severity missing authorization vulnerability in YAFNET, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

YetAnotherForum.NET (YAF.NET) is a C# ASP.NET forum. Prior to 4.0.5, Any admin OnPost… handler executes its side effects before the ResultFilterAttribute rewrites the response to a 302 to /Info/4. The most impactful abuse is /Admin/RunSql, whose OnPostRunQuery binds Editor from the POST body and passes it straight to IDbAccess.RunSql with no caller check, yielding arbitrary SQL execution for any low-privileged user. This vulnerability is fixed in 4.0.5.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-841 (Improper Enforcement of Behavioral Workflow)

## Which versions are affected by CVE-2026-43937?

2 open source packages ship an affected version, including YAFNET.Core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `YAFNET.Core` | NuGet | All versions | 4.0.5 |
| `YAFNET.Core` | NuGet | All versions | 4.0.5 |

## How do I fix CVE-2026-43937?

Upgrade YAFNET.Core to 4.0.5 or later.

## Is CVE-2026-43937 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43937 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43937 and fix it if it is affected.

What it is: CVE-2026-43937 is a high-severity missing authorization vulnerability in YAFNET, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43937 exists.

Affected packages and fixed versions:
- YAFNET.Core (NuGet): affected all versions; fixed in 4.0.5
- YAFNET.Core (NuGet): affected all versions; fixed in 4.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43937/ (Markdown: https://insights.sbomify.com/CVE-2026-43937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43937
- OSV: https://osv.dev/vulnerability/CVE-2026-43937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43937/
Summaries are generated and may contain mistakes; the official description above is the record.
