# CVE-2026-43939: YAF.NET: Stored XSS in Forum Thread Posts/Replies Allowing Arbitrary JavaScript Execution for All Thread Viewers

> Attackers can inject malicious JavaScript into forum posts, executing arbitrary code in the browsers of all users viewing the thread.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-8rq5-wwpp-fmj2

## What is CVE-2026-43939?

CVE-2026-43939 is a high-severity cross-site scripting vulnerability in YAFNET, published on 12 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

YetAnotherForum.NET (YAF.NET) is a C# ASP.NET forum. Prior to 4.0.5 and 3.2.12, the thread posting and reply feature accepts user-supplied content via a a post or reply that is stored server-side and later rendered back into the thread page without adequate HTML sanitization or contextual output encoding.  This vulnerability is fixed in 4.0.5 and 3.2.12.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-43939?

4 open source packages ship an affected version, including YAFNET.Core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `YAFNET.Core` | NuGet | All versions | 3.2.12 |
| `YAFNET.Core` | NuGet | All versions | 3.2.12 |
| `YAFNET.Core` | NuGet | From 4.0.0-beta01 | 4.0.5 |
| `YAFNET.Core` | NuGet | From 4.0.0-beta01 | 4.0.5 |

## How do I fix CVE-2026-43939?

Upgrade YAFNET.Core to a fixed version for your release line: 3.2.12 or 4.0.5.

## Is CVE-2026-43939 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43939 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43939 and fix it if it is affected.

What it is: CVE-2026-43939 is a high-severity cross-site scripting vulnerability in YAFNET, published on 12 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43939 exists.

Affected packages and fixed versions:
- YAFNET.Core (NuGet): affected all versions; fixed in 3.2.12
- YAFNET.Core (NuGet): affected all versions; fixed in 3.2.12
- YAFNET.Core (NuGet): affected from 4.0.0-beta01; fixed in 4.0.5
- YAFNET.Core (NuGet): affected from 4.0.0-beta01; fixed in 4.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43939/ (Markdown: https://insights.sbomify.com/CVE-2026-43939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43939
- OSV: https://osv.dev/vulnerability/CVE-2026-43939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43939/
Summaries are generated and may contain mistakes; the official description above is the record.
