# CVE-2026-43940: electerm: Path traversal in electerm runWidget leads to arbitrary code execution

> Attackers can achieve arbitrary code execution via path traversal in the runWidget function, compromising the system.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-f77v-9vpc-6pjm

## What is CVE-2026-43940?

CVE-2026-43940 is a high-severity path traversal vulnerability in electerm, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.7.16, the runWidget function in src/app/widgets/load-widget.js constructs a file path by directly concatenating user‑supplied widget identifiers without any sanitisation. Because runWidget is exposed to the renderer process via an asynchronous IPC handler with no input validation, an attacker who achieves JavaScript execution inside the renderer (for example, through a malicious plugin or a cross‑site scripting flaw in the built‑in webview) can abuse a path traversal (../) to load and execute an arbitrary JavaScript file anywhere on the victim’s filesystem. This gives the attacker local code execution with the full privileges of the electerm process, leading to complete system compromise. This issue has been patched in version 3.7.16.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-43940?

2 open source packages ship an affected version, including electerm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electerm` | npm | All versions | 3.7.16 |
| `electerm` | npm | All versions | 3.7.16 |

Products: Electerm Project Electerm.

## How do I fix CVE-2026-43940?

Upgrade electerm to 3.7.16 or later.

## Is CVE-2026-43940 being exploited?

There is no known exploitation of CVE-2026-43940 in the wild and no public exploit code.

## Other vulnerabilities in electerm

- [CVE-2026-41500](https://insights.sbomify.com/CVE-2026-41500/): electerm has Command Injection Vulnerability via runMac function (critical 9.8)
- [CVE-2026-41501](https://insights.sbomify.com/CVE-2026-41501/): electerm has Command Injection Vulnerability via runLinux function (critical 9.8)
- [CVE-2020-23256](https://insights.sbomify.com/CVE-2020-23256/): electerm allows unauthorized users to execute arbitrary commands (critical 9.8)
- [CVE-2026-43941](https://insights.sbomify.com/CVE-2026-43941/): Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click (critical 9.6)
- [CVE-2026-43944](https://insights.sbomify.com/CVE-2026-43944/): electerm: dangerous code can be run through links or command line (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43940 and fix it if it is affected.

What it is: CVE-2026-43940 is a high-severity path traversal vulnerability in electerm, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43940 in the wild and no public exploit code.

Affected packages and fixed versions:
- electerm (npm): affected all versions; fixed in 3.7.16
- electerm (npm): affected all versions; fixed in 3.7.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43940/ (Markdown: https://insights.sbomify.com/CVE-2026-43940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43940
- OSV: https://osv.dev/vulnerability/CVE-2026-43940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43940/
Summaries are generated and may contain mistakes; the official description above is the record.
