# CVE-2026-43943: electerm: RCE via malicious SSH server filename in openFileWithEditor

> Attackers can execute arbitrary code on a victim's machine by crafting malicious filenames on a controlled SSH server when the user edits files.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-q4p8-8j9m-8hxj

## What is CVE-2026-43943?

CVE-2026-43943 is a high-severity command injection vulnerability in electerm, published on 8 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.7.9, a code execution (RCE) vulnerability exists in electerm's SFTP open with system editor or "Edit with custom editor" feature. When a user opts to edit a file using open with system editor or open with a custom editor, the filename is passed directly into a command line without sanitization. A malicious actor controlling the SSH server or user OS can exploit this by crafting a filename containing shell metacharacters. If a victim subsequently attempts to edit this file, the injected commands are executed on their machine with the user's privileges. This could allow the attacker to run arbitrary code, install malware, or move laterally within the network. This issue has been patched in version 3.7.9.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-43943?

2 open source packages ship an affected version, including electerm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electerm` | npm | All versions | 3.7.9 |
| `electerm` | npm | All versions | 3.7.9 |

Products: Electerm Project Electerm.

## How do I fix CVE-2026-43943?

Upgrade electerm to 3.7.9 or later.

## Is CVE-2026-43943 being exploited?

There is no known exploitation of CVE-2026-43943 in the wild and no public exploit code.

## Other vulnerabilities in electerm

- [CVE-2026-41500](https://insights.sbomify.com/CVE-2026-41500/): electerm has Command Injection Vulnerability via runMac function (critical 9.8)
- [CVE-2026-41501](https://insights.sbomify.com/CVE-2026-41501/): electerm has Command Injection Vulnerability via runLinux function (critical 9.8)
- [CVE-2020-23256](https://insights.sbomify.com/CVE-2020-23256/): electerm allows unauthorized users to execute arbitrary commands (critical 9.8)
- [CVE-2026-43941](https://insights.sbomify.com/CVE-2026-43941/): Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click (critical 9.6)
- [CVE-2026-43944](https://insights.sbomify.com/CVE-2026-43944/): electerm: dangerous code can be run through links or command line (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43943 and fix it if it is affected.

What it is: CVE-2026-43943 is a high-severity command injection vulnerability in electerm, published on 8 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-43943 in the wild and no public exploit code.

Affected packages and fixed versions:
- electerm (npm): affected all versions; fixed in 3.7.9
- electerm (npm): affected all versions; fixed in 3.7.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43943/ (Markdown: https://insights.sbomify.com/CVE-2026-43943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43943
- OSV: https://osv.dev/vulnerability/CVE-2026-43943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43943/
Summaries are generated and may contain mistakes; the official description above is the record.
