CVE-2026-43944 electerm: dangerous code can be run through links or command line

Critical 9.4 Published Updated

Attackers can execute arbitrary local code by tricking users into clicking crafted deep links or opening malicious shortcuts in the electerm terminal client.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-43944?

CVE-2026-43944 is a critical code injection vulnerability in electerm, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

Weakness: CWE-94, CWE-829, CWE-20

Which versions are affected by CVE-2026-43944?

2 open source packages ship an affected version, including electerm. It affects 1 product.

PackageAffectedFixed in
electerm npmFrom 3.0.63.8.8
electerm npmFrom 3.0.63.8.8

Products include Electerm Project Electerm.

How do I fix CVE-2026-43944?

Upgrade electerm to 3.8.8 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-43944 being exploited?

There is no known exploitation of CVE-2026-43944 in the wild and no public exploit code.

Sources

Also known as GHSA-mpm8-cx2p-626q.

Is CVE-2026-43944 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free