{"answers":{"affected":"2 open source packages ship an affected version, including electerm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-43944 in the wild and no public exploit code.","fix":"Upgrade electerm to 3.8.8 or later.","what":"CVE-2026-43944 is a critical code injection vulnerability in electerm, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-43944 and fix it if it is affected.\n\nWhat it is: CVE-2026-43944 is a critical code injection vulnerability in electerm, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-43944 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- electerm (npm): affected from 3.0.6; fixed in 3.8.8\n- electerm (npm): affected from 3.0.6; fixed in 3.8.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-43944/ (Markdown: https://insights.sbomify.com/CVE-2026-43944/index.md)","id":"CVE-2026-43944","markdown":"https://insights.sbomify.com/CVE-2026-43944/index.md","name":"CVE-2026-43944","record":{"aliases":["GHSA-mpm8-cx2p-626q"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"terminal client","requires_auth":"none","summary":"Attackers can execute arbitrary local code by tricking users into clicking crafted deep links or opening malicious shortcuts in the electerm terminal client.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"electerm","vendor":"electerm_project"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"electerm: dangerous code can be run through links or command line","id":"CVE-2026-43944","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"FUXA Vulnerable to Pre-auth RCE via Path Manipulation \u0026 Configuration Injection","id":"CVE-2026-43945"},"packages":[{"ecosystem":"npm","fixed":["3.8.8"],"introduced":["3.0.6"],"last_affected":[],"package":"electerm","purl":null,"source":"GHSA-mpm8-cx2p-626q"},{"ecosystem":"npm","fixed":["3.8.8"],"introduced":["3.0.6"],"last_affected":[],"package":"electerm","purl":"pkg:npm/electerm","source":"GHSA-mpm8-cx2p-626q"}],"prev":{"headline":"electerm: RCE via malicious SSH server filename in openFileWithEditor","id":"CVE-2026-43943"},"products":["electerm"],"published":"2026-05-08","related":[{"cvss_score":9.8,"headline":"electerm has Command Injection Vulnerability via runMac function","id":"CVE-2026-41500","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.8,"headline":"electerm has Command Injection Vulnerability via runLinux function","id":"CVE-2026-41501","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.8,"headline":"electerm allows unauthorized users to execute arbitrary commands","id":"CVE-2020-23256","kev_date_added":null,"published":"2023-01-20"},{"cvss_score":9.6,"headline":"Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click","id":"CVE-2026-43941","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.3,"headline":"electerm: Local code through electerm's single-instance socket","id":"CVE-2026-45353","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.4,"headline":"electerm: Path traversal in electerm runWidget leads to arbitrary code execution","id":"CVE-2026-43940","kev_date_added":null,"published":"2026-05-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["electerm"]},"summary":"Attackers can execute arbitrary local code by tricking users into clicking crafted deep links or opening malicious shortcuts in the electerm terminal client.","url":"https://insights.sbomify.com/CVE-2026-43944/"}