# CVE-2026-43944: electerm: dangerous code can be run through links or command line

> Attackers can execute arbitrary local code by tricking users into clicking crafted deep links or opening malicious shortcuts in the electerm terminal client.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-mpm8-cx2p-626q

## What is CVE-2026-43944?

CVE-2026-43944 is a critical code injection vulnerability in electerm, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-43944?

2 open source packages ship an affected version, including electerm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electerm` | npm | From 3.0.6 | 3.8.8 |
| `electerm` | npm | From 3.0.6 | 3.8.8 |

Products: Electerm Project Electerm.

## How do I fix CVE-2026-43944?

Upgrade electerm to 3.8.8 or later.

## Is CVE-2026-43944 being exploited?

There is no known exploitation of CVE-2026-43944 in the wild and no public exploit code.

## Other vulnerabilities in electerm

- [CVE-2026-41500](https://insights.sbomify.com/CVE-2026-41500/): electerm has Command Injection Vulnerability via runMac function (critical 9.8)
- [CVE-2026-41501](https://insights.sbomify.com/CVE-2026-41501/): electerm has Command Injection Vulnerability via runLinux function (critical 9.8)
- [CVE-2020-23256](https://insights.sbomify.com/CVE-2020-23256/): electerm allows unauthorized users to execute arbitrary commands (critical 9.8)
- [CVE-2026-43941](https://insights.sbomify.com/CVE-2026-43941/): Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click (critical 9.6)
- [CVE-2026-45353](https://insights.sbomify.com/CVE-2026-45353/): electerm: Local code through electerm's single-instance socket (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43944 and fix it if it is affected.

What it is: CVE-2026-43944 is a critical code injection vulnerability in electerm, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-43944 in the wild and no public exploit code.

Affected packages and fixed versions:
- electerm (npm): affected from 3.0.6; fixed in 3.8.8
- electerm (npm): affected from 3.0.6; fixed in 3.8.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43944/ (Markdown: https://insights.sbomify.com/CVE-2026-43944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43944
- OSV: https://osv.dev/vulnerability/CVE-2026-43944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43944/
Summaries are generated and may contain mistakes; the official description above is the record.
