{"answers":{"affected":"2 open source packages ship an affected version, including @frangoteam/fuxa.","exploited":"There is no known exploitation of CVE-2026-43945 in the wild and no public exploit code.","fix":"Upgrade @frangoteam/fuxa to 1.3.1 or later.","what":"CVE-2026-43945 is a high-severity code injection vulnerability in frangoteam FUXA, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-43945 and fix it if it is affected.\n\nWhat it is: CVE-2026-43945 is a high-severity code injection vulnerability in frangoteam FUXA, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-43945 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @frangoteam/fuxa (npm): affected from 1.2.11; fixed in 1.3.1\n- @frangoteam/fuxa (npm): affected from 1.2.11; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-43945/ (Markdown: https://insights.sbomify.com/CVE-2026-43945/index.md)","id":"CVE-2026-43945","markdown":"https://insights.sbomify.com/CVE-2026-43945/index.md","name":"CVE-2026-43945","record":{"aliases":["GHSA-p69w-mmfv-xrfj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"SCADA HMI software","requires_auth":"none","summary":"Unauthenticated attackers can achieve root-level remote code execution in FUXA SCADA software via path manipulation and configuration injection.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. Versions 1.2.11 until 1.3.1 allow an unauthenticated remote attacker to achieve Full Remote Code Execution (RCE) as root. The exploit succeeds even when the platform is configured in its most secure state (Secure Mode Enabled and Node-RED Secure Auth Enabled). Version 1.3.1 fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FUXA Vulnerable to Pre-auth RCE via Path Manipulation \u0026 Configuration Injection","id":"CVE-2026-43945","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"FUXA has an unauthenticated arbitrary tag value disclosure via /api/getTagValue","id":"CVE-2026-43946"},"packages":[{"ecosystem":"npm","fixed":["1.3.1"],"introduced":["1.2.11"],"last_affected":[],"package":"@frangoteam/fuxa","purl":null,"source":"GHSA-p69w-mmfv-xrfj"},{"ecosystem":"npm","fixed":["1.3.1"],"introduced":["1.2.11"],"last_affected":[],"package":"@frangoteam/fuxa","purl":"pkg:npm/%40frangoteam/fuxa","source":"GHSA-p69w-mmfv-xrfj"}],"prev":{"headline":"electerm: dangerous code can be run through links or command line","id":"CVE-2026-43944"},"products":["FUXA"],"published":"2026-07-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-22","vendors":["frangoteam"]},"summary":"Unauthenticated attackers can achieve root-level remote code execution in FUXA SCADA software via path manipulation and configuration injection.","url":"https://insights.sbomify.com/CVE-2026-43945/"}