# CVE-2026-43945: FUXA Vulnerable to Pre-auth RCE via Path Manipulation & Configuration Injection

> Unauthenticated attackers can achieve root-level remote code execution in FUXA SCADA software via path manipulation and configuration injection.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** GHSA-p69w-mmfv-xrfj

## What is CVE-2026-43945?

CVE-2026-43945 is a high-severity code injection vulnerability in frangoteam FUXA, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. Versions 1.2.11 until 1.3.1 allow an unauthenticated remote attacker to achieve Full Remote Code Execution (RCE) as root. The exploit succeeds even when the platform is configured in its most secure state (Secure Mode Enabled and Node-RED Secure Auth Enabled). Version 1.3.1 fixes the issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-863 (Incorrect Authorization), CWE-288 (Authentication Bypass Using an Alternate Path or Channel), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-43945?

2 open source packages ship an affected version, including @frangoteam/fuxa.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@frangoteam/fuxa` | npm | From 1.2.11 | 1.3.1 |
| `@frangoteam/fuxa` | npm | From 1.2.11 | 1.3.1 |

## How do I fix CVE-2026-43945?

Upgrade @frangoteam/fuxa to 1.3.1 or later.

## Is CVE-2026-43945 being exploited?

There is no known exploitation of CVE-2026-43945 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43945 and fix it if it is affected.

What it is: CVE-2026-43945 is a high-severity code injection vulnerability in frangoteam FUXA, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43945 in the wild and no public exploit code.

Affected packages and fixed versions:
- @frangoteam/fuxa (npm): affected from 1.2.11; fixed in 1.3.1
- @frangoteam/fuxa (npm): affected from 1.2.11; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43945/ (Markdown: https://insights.sbomify.com/CVE-2026-43945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43945
- OSV: https://osv.dev/vulnerability/CVE-2026-43945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43945/
Summaries are generated and may contain mistakes; the official description above is the record.
