# CVE-2026-43968: CR Injection in SSE Encoder Enables Event Splitting via cow_sse:event/1

> Attackers can inject CRLF sequences in SSE events to forge arbitrary event types and data, potentially leading to client-side code execution or XSS.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 12 May 2026
- **Also known as:** AZL-86793, EEF-CVE-2026-43968, GHSA-hv23-4qp7-8c8r

## What is CVE-2026-43968?

CVE-2026-43968 is a medium-severity vulnerability in ninenines cowlib, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of CRLF Sequences ('CRLF Injection') vulnerability in ninenines cowlib allows SSE event splitting and injection via unvalidated field values.

cow_sse:event/1 in cowlib guards the id and event fields against \n but not against bare \r, and the internal prefix_lines/2 function used for data and comment fields splits only on \n. Because the SSE specification requires decoders to treat \r\n, \r, and \n as equivalent line terminators, an attacker who controls any of these fields can inject additional SSE lines and forge a complete event with an arbitrary event type and data payload on the receiving end. In typical deployments where browser EventSource clients or other SSE consumers dispatch on event.type and render event.data, this enables event splitting, client-side logic manipulation, and stored-XSS-equivalent behaviour when event data is inserted into the DOM.

This issue affects cowlib from 2.6.0 before 2.16.1.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-43968?

3 open source packages ship an affected version, including cowlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cowlib` | Hex | From 2.6.0 | 2.16.1 |
| `cowlib` | Hex | From 2.6.0 | 2.16.1 |
| `cowlib` | Hex | From 2.6.0 | 2.16.1 |

Products: Ninenines Cowlib.

## How do I fix CVE-2026-43968?

Upgrade cowlib to 2.16.1 or later.

## Is CVE-2026-43968 being exploited?

There is no known exploitation of CVE-2026-43968 in the wild and no public exploit code.

## Other vulnerabilities in ninenines cowlib

- [CVE-2026-7790](https://insights.sbomify.com/CVE-2026-7790/): Unbounded chunk-size hex digits in cowlib cause quadratic CPU and memory DoS (high 8.7)
- [CVE-2026-43966](https://insights.sbomify.com/CVE-2026-43966/): HTTP Response Splitting via Non-VCHAR Bytes in cow_http_struct_hd:escape_string/2 (medium 6.3)
- [CVE-2026-43969](https://insights.sbomify.com/CVE-2026-43969/): Cookie Request Header Injection via Unvalidated Encoder in cow_cookie:cookie/1 (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43968 and fix it if it is affected.

What it is: CVE-2026-43968 is a medium-severity vulnerability in ninenines cowlib, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43968 in the wild and no public exploit code.

Affected packages and fixed versions:
- cowlib (Hex): affected from 2.6.0; fixed in 2.16.1
- cowlib (Hex): affected from 2.6.0; fixed in 2.16.1
- cowlib (Hex): affected from 2.6.0; fixed in 2.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43968/ (Markdown: https://insights.sbomify.com/CVE-2026-43968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43968
- OSV: https://osv.dev/vulnerability/CVE-2026-43968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43968/
Summaries are generated and may contain mistakes; the official description above is the record.
