# CVE-2026-43972: gun HTTP/2 PUSH_PROMISE authority not validated against connection origin allows cross-origin cookie injection

> A malicious HTTP/2 server can inject cookies for arbitrary domains via unvalidated PUSH_PROMISE frames, potentially leading to account takeover.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** EEF-CVE-2026-43972, GHSA-36w4-95hv-5vwg

## What is CVE-2026-43972?

CVE-2026-43972 is a medium-severity vulnerability in ninenines gun, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Origin Validation Error vulnerability in ninenines gun (gun_http2 module) allows cross-origin cookie injection via unvalidated HTTP/2 PUSH_PROMISE authority.

In gun_http2:push_promise_frame/7, the :authority pseudo-header from an incoming PUSH_PROMISE frame is stored verbatim into the promised stream record without checking that it matches the connection's origin. When gun_http2:headers_frame/9 later processes the response headers for the promised stream, it calls gun_cookies:set_cookie_header/7 with the unvalidated server-supplied authority before any status branching and before user code can act. This violates RFC 7540 §10.6 / RFC 9113 §8.4, which require receivers to treat as a protocol error any push for a resource the server is not authoritative for.

A malicious or compromised HTTP/2 server can plant cookies scoped to arbitrary third-party domains into the client's shared cookie store. This enables session fixation attacks against those domains and, if the planted cookie overrides a legitimate session token, may result in account takeover. No user interaction beyond making a normal HTTP/2 request to the attacker-controlled server is required.

This issue affects gun: from 2.0.0 before 2.4.0.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-43972?

3 open source packages ship an affected version, including gun. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gun` | Hex | From 2.0.0 | 2.4.0 |
| `gun` | Hex | From 2.0.0 | 2.4.0 |
| `gun` | Hex | From 2.0.0 | 2.4.0 |

Products: Ninenines Gun.

## How do I fix CVE-2026-43972?

Upgrade gun to 2.4.0 or later.

## Is CVE-2026-43972 being exploited?

There is no known exploitation of CVE-2026-43972 in the wild and no public exploit code.

## Other vulnerabilities in ninenines gun

- [CVE-2026-43973](https://insights.sbomify.com/CVE-2026-43973/): gun HTTP/1.1 response buffer has no size limit allowing server-controlled memory exhaustion (high 8.7)
- [CVE-2026-43974](https://insights.sbomify.com/CVE-2026-43974/): gun HTTP/1.1 client accepts unsolicited 101 Switching Protocols response allowing server-driven protocol hijack and OOM (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43972 and fix it if it is affected.

What it is: CVE-2026-43972 is a medium-severity vulnerability in ninenines gun, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43972 in the wild and no public exploit code.

Affected packages and fixed versions:
- gun (Hex): affected from 2.0.0; fixed in 2.4.0
- gun (Hex): affected from 2.0.0; fixed in 2.4.0
- gun (Hex): affected from 2.0.0; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43972/ (Markdown: https://insights.sbomify.com/CVE-2026-43972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43972
- OSV: https://osv.dev/vulnerability/CVE-2026-43972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43972/
Summaries are generated and may contain mistakes; the official description above is the record.
