# CVE-2026-43974: gun HTTP/1.1 client accepts unsolicited 101 Switching Protocols response allowing server-driven protocol hijack and OOM

> A malicious server can force the gun HTTP client into raw mode via unsolicited 101 responses, causing memory exhaustion and VM crashes.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** EEF-CVE-2026-43974, GHSA-2j82-37xg-f9wp

## What is CVE-2026-43974?

CVE-2026-43974 is a high-severity denial of service vulnerability in ninenines gun, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unexpected Status Code or Return Value vulnerability in ninenines gun (gun_http module) allows a malicious HTTP server to force the client into raw protocol mode via an unsolicited 101 Switching Protocols response.

In gun_http:handle_inform/8, when a 101 Switching Protocols response is received over HTTP/1.1, the function verifies only that the Upgrade header is syntactically valid and that the stream reference is a plain reference(). It does not check whether the client ever sent an Upgrade or Connection: upgrade header on the corresponding request. Because this check is absent, any 101 response (solicited or not) causes gun to dispatch a gun_upgrade message to the caller and transition the entire connection to raw protocol mode.

A malicious or compromised HTTP server can send an unsolicited 101 response to any HTTP/1.1 request, causing the gun client to abandon HTTP framing for that connection. Once in raw mode, gun_raw applies no flow control (flow=infinity) and re-arms socket active mode after every received packet, so the server can flood the client with arbitrary bytes. These are forwarded as unbounded gun_data messages to the owner process, exhausting its mailbox and BEAM memory, ultimately crashing the VM.

This issue affects gun: from 2.0.0 before 2.4.0.

Weakness: CWE-841 (Improper Enforcement of Behavioral Workflow)

## Which versions are affected by CVE-2026-43974?

3 open source packages ship an affected version, including gun. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gun` | Hex | From 2.0.0 | 2.4.0 |
| `gun` | Hex | From 2.0.0 | 2.4.0 |
| `gun` | Hex | From 2.0.0 | 2.4.0 |

Products: Ninenines Gun.

## How do I fix CVE-2026-43974?

Upgrade gun to 2.4.0 or later.

## Is CVE-2026-43974 being exploited?

There is no known exploitation of CVE-2026-43974 in the wild and no public exploit code.

## Other vulnerabilities in ninenines gun

- [CVE-2026-43973](https://insights.sbomify.com/CVE-2026-43973/): gun HTTP/1.1 response buffer has no size limit allowing server-controlled memory exhaustion (high 8.7)
- [CVE-2026-43972](https://insights.sbomify.com/CVE-2026-43972/): gun HTTP/2 PUSH_PROMISE authority not validated against connection origin allows cross-origin cookie injection (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43974 and fix it if it is affected.

What it is: CVE-2026-43974 is a high-severity denial of service vulnerability in ninenines gun, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43974 in the wild and no public exploit code.

Affected packages and fixed versions:
- gun (Hex): affected from 2.0.0; fixed in 2.4.0
- gun (Hex): affected from 2.0.0; fixed in 2.4.0
- gun (Hex): affected from 2.0.0; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43974/ (Markdown: https://insights.sbomify.com/CVE-2026-43974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43974
- OSV: https://osv.dev/vulnerability/CVE-2026-43974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43974/
Summaries are generated and may contain mistakes; the official description above is the record.
