# CVE-2026-43975: Apache Wicket: Possible malicious path traversal in FolderUploadsFileManager

> Unauthenticated attackers can read or write arbitrary files on the server via path traversal in Apache Wicket's FolderUploadsFileManager.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-3gmf-p6r4-q8m6

## What is CVE-2026-43975?

CVE-2026-43975 is a medium-severity path traversal vulnerability in Apache Wicket, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FolderUploadsFileManager in Apache Wicket does not validate or sanitize the uploadFieldId parameter or the clientFileName
 before constructing file paths, allowing an unauthenticated attacker to
 write arbitrary files outside the intended upload directory or read 
files from arbitrary locations on the server.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-43975?

6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.wicket:wicket-core` | Maven | From 10.0.0-M1 | 10.9.0 |
| `org.apache.wicket:wicket-core` | Maven | From 10.0.0-M1 | 10.9.0 |
| `org.apache.wicket:wicket-core` | Maven | From 8.0.0-M1 to 8.17.0 | None |
| `org.apache.wicket:wicket-core` | Maven | From 8.0.0-M1 to 8.17.0 | None |
| `org.apache.wicket:wicket-core` | Maven | From 9.0.0-M1 to 9.22.0 | None |
| `org.apache.wicket:wicket-core` | Maven | From 9.0.0-M1 to 9.22.0 | None |

Products: Apache Wicket.

## How do I fix CVE-2026-43975?

Upgrade org.apache.wicket:wicket-core to 10.9.0 or later.

## Is CVE-2026-43975 being exploited?

There is no known exploitation of CVE-2026-43975 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43975 and fix it if it is affected.

What it is: CVE-2026-43975 is a medium-severity path traversal vulnerability in Apache Wicket, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-43975 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.wicket:wicket-core (Maven): affected from 10.0.0-M1; fixed in 10.9.0
- org.apache.wicket:wicket-core (Maven): affected from 10.0.0-M1; fixed in 10.9.0
- org.apache.wicket:wicket-core (Maven): affected from 8.0.0-M1 up to 8.17.0; no fix listed
- org.apache.wicket:wicket-core (Maven): affected from 8.0.0-M1 up to 8.17.0; no fix listed
- org.apache.wicket:wicket-core (Maven): affected from 9.0.0-M1 up to 9.22.0; no fix listed
- org.apache.wicket:wicket-core (Maven): affected from 9.0.0-M1 up to 9.22.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43975/ (Markdown: https://insights.sbomify.com/CVE-2026-43975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43975
- OSV: https://osv.dev/vulnerability/CVE-2026-43975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43975/
Summaries are generated and may contain mistakes; the official description above is the record.
