# CVE-2026-43983: Pocket ID: OIDC refresh token flow bypasses authorization revocation, account disabling, and group restrictions

> Attackers can maintain access via refresh tokens after authorization revocation, account disabling, or group removal in Pocket ID.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-w6p7-2fxx-4f44, GO-2026-6119

## What is CVE-2026-43983?

CVE-2026-43983 is a high-severity authentication bypass vulnerability in pocket-id, published on 12 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to your services. Prior to 2.6.0, The createTokenFromRefreshToken function (oidc_service.go) validates the refresh token's cryptographic integrity but does not re-validate the user's current authorization state before issuing new tokens. This allows (1) the client to refresh the token indefinitely after authorization revocation, (2) the refresh token to continue to work after the account is disabled, and (3) the token to work after the client is removed from the group. This vulnerability is fixed in 2.6.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-43983?

3 open source packages ship an affected version, including github.com/pocket-id/pocket-id/backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pocket-id/pocket-id/backend` | Go | All versions | 0.0.0-20260419162744-978ac87deffe |
| `github.com/pocket-id/pocket-id/backend` | Go | All versions | 0.0.0-20260419162744-978ac87deffe |
| `github.com/pocket-id/pocket-id/backend` | Go | All versions | 0.0.0-20260419162744-978ac87deffe |

Products: Pocket-Id Pocket Id.

## How do I fix CVE-2026-43983?

Upgrade github.com/pocket-id/pocket-id/backend to 0.0.0-20260419162744-978ac87deffe or later.

## Is CVE-2026-43983 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43983 exists.

## Other vulnerabilities in pocket-id

- [CVE-2026-28513](https://insights.sbomify.com/CVE-2026-28513/): Pocket ID: OIDC authorization code validation uses AND instead of OR, allowing cross-client token exchange (high 8.5)
- [CVE-2026-28512](https://insights.sbomify.com/CVE-2026-28512/): Pocket ID: OAuth redirect_uri validation bypass via userinfo/host confusion (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-43983 and fix it if it is affected.

What it is: CVE-2026-43983 is a high-severity authentication bypass vulnerability in pocket-id, published on 12 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43983 exists.

Affected packages and fixed versions:
- github.com/pocket-id/pocket-id/backend (Go): affected all versions; fixed in 0.0.0-20260419162744-978ac87deffe
- github.com/pocket-id/pocket-id/backend (Go): affected all versions; fixed in 0.0.0-20260419162744-978ac87deffe
- github.com/pocket-id/pocket-id/backend (Go): affected all versions; fixed in 0.0.0-20260419162744-978ac87deffe

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-43983/ (Markdown: https://insights.sbomify.com/CVE-2026-43983/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-43983
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-43983
- OSV: https://osv.dev/vulnerability/CVE-2026-43983

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-43983/
Summaries are generated and may contain mistakes; the official description above is the record.
