{"answers":{"affected":"4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43995 exists.","fix":"Upgrade flowise to 3.1.0 or later.","what":"CVE-2026-43995 is a medium-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-43995 and fix it if it is affected.\n\nWhat it is: CVE-2026-43995 is a medium-severity server-side request forgery vulnerability in Flowiseai Flowise, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-43995 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.1.0\n- flowise (npm): affected all versions; fixed in 3.1.0\n- flowise-components (npm): affected all versions; fixed in 3.1.0\n- flowise-components (npm): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-43995/ (Markdown: https://insights.sbomify.com/CVE-2026-43995/index.md)","id":"CVE-2026-43995","markdown":"https://insights.sbomify.com/CVE-2026-43995/index.md","name":"CVE-2026-43995","record":{"aliases":["GHSA-qqvm-66q4-vf5c"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM flow builder","requires_auth":"low_privilege","summary":"Attackers can bypass SSRF protections in Flowise by exploiting tools that use raw HTTP clients, potentially accessing internal network resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.0, multiple tool implementations directly import and invoke raw HTTP clients (node-fetch, axios) instead of using the secured wrapper. These tools include (1) OpenAPIToolkit/OpenAPIToolkit.ts, (2) WebScraperTool/WebScraperTool.ts, (3) MCP/core.ts, and (4) Arxiv/core.ts. This vulnerability is fixed in 3.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise: SSRF Protection Bypass via Direct node-fetch / axios Usage (Patch Enforcement Failure)","id":"CVE-2026-43995","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"ssrf","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Integer overflow in OpenImageIO","id":"CVE-2026-43996"},"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-qqvm-66q4-vf5c"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-qqvm-66q4-vf5c"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":null,"source":"GHSA-qqvm-66q4-vf5c"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":"pkg:npm/flowise-components","source":"GHSA-qqvm-66q4-vf5c"}],"prev":{"headline":"Coturn: Stack buffer overflow in decode_oauth_token_gcm()","id":"CVE-2026-43994"},"products":["Flowise"],"published":"2026-05-11","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["FlowiseAI"]},"summary":"Attackers can bypass SSRF protections in Flowise by exploiting tools that use raw HTTP clients, potentially accessing internal network resources.","url":"https://insights.sbomify.com/CVE-2026-43995/"}