# CVE-2026-44001: vm2: Sandbox Escape via Promise Constructor Unhandled Rejection (Process Crash DoS)


- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 7 Sep 2026
- **Also known as:** GHSA-hw58-p9xv-2mjh, ROOT-APP-NPM-CVE-2026-44001

## What is CVE-2026-44001?

CVE-2026-44001 is a high-severity vulnerability in patriksimek vm2, published on 13 May 2026. 

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.0, a sandbox escape vulnerability in vm2 v3.10.5 allows any sandboxed code to crash the host Node.js process via a single Promise constructor that triggers an unhandled rejection propagating to the host. The fix for CVE-2026-22709 (v3.10.2) only sanitized the onRejected callback in .then() and .catch() overrides and did not address the executor-to-unhandledRejection path. This vulnerability is fixed in 3.11.0.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-44001?

2 open source packages ship an affected version, including vm2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.0 |
| `vm2` | npm | All versions | 3.11.0 |

Products: Vm2 Project Vm2.

## How do I fix CVE-2026-44001?

Upgrade vm2 to 3.11.0 or later.

## Is CVE-2026-44001 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44001 exists.

## Other vulnerabilities in patriksimek vm2

- [CVE-2026-43997](https://insights.sbomify.com/CVE-2026-43997/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2026-44005](https://insights.sbomify.com/CVE-2026-44005/): vm2: Sandbox escape (critical 10.0)
- [CVE-2026-44006](https://insights.sbomify.com/CVE-2026-44006/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2023-29017](https://insights.sbomify.com/CVE-2023-29017/): vm2 Sandbox Escape vulnerability (critical 10.0)
- [CVE-2022-36067](https://insights.sbomify.com/CVE-2022-36067/): vm2 vulnerable to Sandbox Escape before v3.9.11 (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44001 and fix it if it is affected.

What it is: CVE-2026-44001 is a high-severity vulnerability in patriksimek vm2, published on 13 May 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44001 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.0
- vm2 (npm): affected all versions; fixed in 3.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44001/ (Markdown: https://insights.sbomify.com/CVE-2026-44001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44001
- OSV: https://osv.dev/vulnerability/CVE-2026-44001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44001/
Summaries are generated and may contain mistakes; the official description above is the record.
