# CVE-2026-44007: vm2: nesting: true bypasses require: false, allowing sandbox escape to arbitrary OS command execution

> Attackers can escape the sandbox and execute arbitrary OS commands if nesting is enabled, regardless of require restrictions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 7 Sep 2026
- **Also known as:** ECHO-fd8b-b31c-648d, GHSA-8hg8-63c5-gwmx, ROOT-APP-NPM-CVE-2026-44007

## What is CVE-2026-44007?

CVE-2026-44007 is a critical code injection vulnerability in patriksimek vm2, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.1, when a NodeVM is created with nesting: true, sandbox code can unconditionally require('vm2') regardless of the outer VM's require configuration — including require: false. With access to vm2, the sandbox constructs a new inner NodeVM with its own unrestricted require settings and executes arbitrary OS commands on the host. Any application that runs untrusted code inside a NodeVM with nesting: true is fully compromised. This vulnerability is fixed in 3.11.1.

Weakness: CWE-1100 (Insufficient Isolation of System-Dependent Functions), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-44007?

2 open source packages ship an affected version, including vm2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.1 |
| `vm2` | npm | All versions | 3.11.1 |

Products: Vm2 Project Vm2.

## How do I fix CVE-2026-44007?

Upgrade vm2 to 3.11.1 or later.

## Is CVE-2026-44007 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44007 exists.

## Other vulnerabilities in patriksimek vm2

- [CVE-2026-43997](https://insights.sbomify.com/CVE-2026-43997/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2026-44005](https://insights.sbomify.com/CVE-2026-44005/): vm2: Sandbox escape (critical 10.0)
- [CVE-2026-44006](https://insights.sbomify.com/CVE-2026-44006/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2023-29017](https://insights.sbomify.com/CVE-2023-29017/): vm2 Sandbox Escape vulnerability (critical 10.0)
- [CVE-2022-36067](https://insights.sbomify.com/CVE-2022-36067/): vm2 vulnerable to Sandbox Escape before v3.9.11 (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44007 and fix it if it is affected.

What it is: CVE-2026-44007 is a critical code injection vulnerability in patriksimek vm2, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44007 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.1
- vm2 (npm): affected all versions; fixed in 3.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44007/ (Markdown: https://insights.sbomify.com/CVE-2026-44007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44007
- OSV: https://osv.dev/vulnerability/CVE-2026-44007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44007/
Summaries are generated and may contain mistakes; the official description above is the record.
