CVE-2026-44010 Craft CMS: Missing Authorization in GraphQL Address Resolver Allows Cross-Scope PII Disclosure
Craft CMS GraphQL API allows low-privilege tokens to read all user addresses, exposing sensitive PII due to missing scope filtering.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44010?
CVE-2026-44010 is a high-severity missing authorization vulnerability in craftcms cms, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft CMS is a content management system (CMS). From 4.0.0 to before 4.17.12 and 5.9.18, the GraphQL Address element resolver (src/gql/resolvers/elements/Address.php) performs no schema scope filtering on top-level queries. A GraphQL API token scoped to a single low-privilege user group can read every address in the system, including addresses belonging to users in groups the token has no authorization to access. This exposes PII, including full names, addresses, organizations, tax IDs, etc. This vulnerability is fixed in 4.17.12 and 5.9.18.
Weakness: CWE-862
Which versions are affected by CVE-2026-44010?
4 open source packages ship an affected version, including craftcms/cms.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0 | 4.17.12 |
craftcms/cms Packagist | From 4.0.0 | 4.17.12 |
craftcms/cms Packagist | From 5.0.0 | 5.9.18 |
craftcms/cms Packagist | From 5.0.0 | 5.9.18 |
How do I fix CVE-2026-44010?
Upgrade craftcms/cms to a fixed version for your release line: 4.17.12 or 5.9.18.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-44010 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44010 exists.
Sources
Also known as GHSA-gj2p-p9m4-c8gw.