# CVE-2026-44010: Craft CMS: Missing Authorization in GraphQL Address Resolver Allows Cross-Scope PII Disclosure

> Craft CMS GraphQL API allows low-privilege tokens to read all user addresses, exposing sensitive PII due to missing scope filtering.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-gj2p-p9m4-c8gw

## What is CVE-2026-44010?

CVE-2026-44010 is a high-severity missing authorization vulnerability in craftcms cms, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS is a content management system (CMS). From 4.0.0 to before 4.17.12 and 5.9.18, the GraphQL Address element resolver (src/gql/resolvers/elements/Address.php) performs no schema scope filtering on top-level queries. A GraphQL API token scoped to a single low-privilege user group can read every address in the system, including addresses belonging to users in groups the token has no authorization to access. This exposes PII, including full names, addresses, organizations, tax IDs, etc. This vulnerability is fixed in 4.17.12 and 5.9.18.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-44010?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.17.12 |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.17.12 |
| `craftcms/cms` | Packagist | From 5.0.0 | 5.9.18 |
| `craftcms/cms` | Packagist | From 5.0.0 | 5.9.18 |

## How do I fix CVE-2026-44010?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.12 or 5.9.18.

## Is CVE-2026-44010 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44010 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44010 and fix it if it is affected.

What it is: CVE-2026-44010 is a high-severity missing authorization vulnerability in craftcms cms, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44010 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.17.12
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.17.12
- craftcms/cms (Packagist): affected from 5.0.0; fixed in 5.9.18
- craftcms/cms (Packagist): affected from 5.0.0; fixed in 5.9.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44010/ (Markdown: https://insights.sbomify.com/CVE-2026-44010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44010
- OSV: https://osv.dev/vulnerability/CVE-2026-44010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44010/
Summaries are generated and may contain mistakes; the official description above is the record.
