# CVE-2026-44011: Craft CMS: Potential authenticated Remote Code Execution via malicious attached Behavior

> Authenticated attackers can execute arbitrary commands on Craft CMS servers by injecting malicious configuration into field layout data.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-qrgm-p9w5-rrfw

## What is CVE-2026-44011?

CVE-2026-44011 is a high-severity code injection vulnerability in craftcms cms, published on 12 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft CMS is a content management system (CMS). From 4.0.0 to before 4.17.12 and 5.9.18, Craft CMS which contains an input-handling flaw in a Yii object creation path that let any authenticated user inject malicious configuration and execute arbitrary commands on the server. The request-controlled condition field layouts data is converted into a live FieldLayout object without a Component::cleanseConfig() boundary. Because Craft configures models before parent::__construct(), attacker-controlled special config keys can take effect during object creation, and FieldLayout initialization then triggers a same-request event. This vulnerability is fixed in 4.17.12 and 5.9.18.

Weakness: CWE-479 (Signal Handler Use of a Non-reentrant Function)

## Which versions are affected by CVE-2026-44011?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.17.12 |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.17.12 |
| `craftcms/cms` | Packagist | From 5.0.0 | 5.9.18 |
| `craftcms/cms` | Packagist | From 5.0.0 | 5.9.18 |

## How do I fix CVE-2026-44011?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.12 or 5.9.18.

## Is CVE-2026-44011 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44011 exists.

Public exploit code:

- The PoC of CVE-2026-44011: Craft CMS RCE with an authenticated user.  (github_poc): https://github.com/4xura/CVE-2026-44011-craftcms-auth-rce
- CVE-2026-44011-craft-rce-poc (github_poc): https://github.com/Cyberuser-hash/CVE-2026-44011-craft-rce-poc
- https://github.com/khush-613/CVE-2026-44011-poc (github_poc): https://github.com/khush-613/CVE-2026-44011-poc
- Craft CMS CVE-2026-44011 condition FieldLayout RCE PoC (github_poc): https://github.com/TRX-0/CVE-2026-44011-craftcms-rce
- Authenticated Craft CMS RCE PoC for CVE-2026-44011 (github_poc): https://github.com/DENNISDGR/CVE-2026-44011-poc
- This is a PoC of the CVE-2026-44011 found by precicom-vincent-tl. For more details check: https://github.com/advisories/GHSA-qrgm-p9w5-rrfw (github_poc): https://github.com/0xyngtg/CraftCMS-CVE-2026-44011-PoC-RCE

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44011 and fix it if it is affected.

What it is: CVE-2026-44011 is a high-severity code injection vulnerability in craftcms cms, published on 12 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44011 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.17.12
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.17.12
- craftcms/cms (Packagist): affected from 5.0.0; fixed in 5.9.18
- craftcms/cms (Packagist): affected from 5.0.0; fixed in 5.9.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44011/ (Markdown: https://insights.sbomify.com/CVE-2026-44011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44011
- OSV: https://osv.dev/vulnerability/CVE-2026-44011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44011/
Summaries are generated and may contain mistakes; the official description above is the record.
