# CVE-2026-44016: Docling: Unsafe Playwright-based HTML Rendering

> Attackers can trigger SSRF and arbitrary code execution via malicious HTML when the optional Playwright rendering backend is enabled.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-pj2v-ggqh-cmq2, PYSEC-2026-2142

## What is CVE-2026-44016?

CVE-2026-44016 is a high-severity server-side request forgery vulnerability in docling-project docling, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. FIn versions >= 2.82.0, < 2.91.0, if the HTML backend was explicitly configured for rendering (rendering option by default deactivated), then the Playwright-based rendering feature could allow JavaScript execution and unrestricted network access when processing untrusted HTML documents. An attacker could craft malicious HTML that executes arbitrary JavaScript in the rendering context or makes unauthorized network requests to internal services, potentially leading to SSRF attacks, data exfiltration, or remote code execution in the rendering environment. This vulnerability is fixed in 2.91.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44016?

3 open source packages ship an affected version, including docling. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.82.0 | 2.91.0 |
| `docling` | PyPI | From 2.82.0 | 2.91.0 |
| `docling` | PyPI | From 2.82.0 | 2.91.0 |

Products: Docling Docling.

## How do I fix CVE-2026-44016?

Upgrade docling to 2.91.0 or later.

## Is CVE-2026-44016 being exploited?

There is no known exploitation of CVE-2026-44016 in the wild and no public exploit code.

## Other vulnerabilities in docling-project docling

- [CVE-2026-105744](https://insights.sbomify.com/CVE-2026-105744/): Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine (high 7.5)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)
- [CVE-2026-105751](https://insights.sbomify.com/CVE-2026-105751/): Docling: Arbitrary local file read via draw:image xlink:href in the OpenDocument backend (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44016 and fix it if it is affected.

What it is: CVE-2026-44016 is a high-severity server-side request forgery vulnerability in docling-project docling, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44016 in the wild and no public exploit code.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.82.0; fixed in 2.91.0
- docling (PyPI): affected from 2.82.0; fixed in 2.91.0
- docling (PyPI): affected from 2.82.0; fixed in 2.91.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44016/ (Markdown: https://insights.sbomify.com/CVE-2026-44016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44016
- OSV: https://osv.dev/vulnerability/CVE-2026-44016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44016/
Summaries are generated and may contain mistakes; the official description above is the record.
