# CVE-2026-44018: Docling: Unsafe Archive Extraction and XML Parsing in METS-GBS Backend

> Attackers can exploit unsafe XML parsing and archive extraction in Docling to read sensitive files or cause denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-r3xg-rg9j-67fv, PYSEC-2026-2144

## What is CVE-2026-44018?

CVE-2026-44018 is a medium-severity vulnerability in docling-project docling, published on 26 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.45.0 until 2.91.0, the METS-GBS backend's XML parsing and the input document format detection lacked security controls. An attacker could craft malicious METS-GBS archives that, when processed, could read sensitive files, exhaust system resources, or cause application crashes. This vulnerability is fixed in 2.91.0.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs), CWE-611 (Improper Restriction of XML External Entity Reference), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-44018?

3 open source packages ship an affected version, including docling. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.45.0 | 2.91.0 |
| `docling` | PyPI | From 2.45.0 | 2.91.0 |
| `docling` | PyPI | From 2.45.0 | 2.91.0 |

Products: Docling Docling.

## How do I fix CVE-2026-44018?

Upgrade docling to 2.91.0 or later.

## Is CVE-2026-44018 being exploited?

There is no known exploitation of CVE-2026-44018 in the wild and no public exploit code.

## Other vulnerabilities in docling-project docling

- [CVE-2026-44016](https://insights.sbomify.com/CVE-2026-44016/): Docling: Unsafe Playwright-based HTML Rendering (high 8.2)
- [CVE-2026-105744](https://insights.sbomify.com/CVE-2026-105744/): Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine (high 7.5)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44018 and fix it if it is affected.

What it is: CVE-2026-44018 is a medium-severity vulnerability in docling-project docling, published on 26 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44018 in the wild and no public exploit code.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.45.0; fixed in 2.91.0
- docling (PyPI): affected from 2.45.0; fixed in 2.91.0
- docling (PyPI): affected from 2.45.0; fixed in 2.91.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44018/ (Markdown: https://insights.sbomify.com/CVE-2026-44018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44018
- OSV: https://osv.dev/vulnerability/CVE-2026-44018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44018/
Summaries are generated and may contain mistakes; the official description above is the record.
