# CVE-2026-44019: Docling Core has insufficient validation of image reference URIs

> Attackers can access local files or cause denial of service via malicious image references in Docling Core applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-j5xp-7m2f-49jv, PYSEC-2026-2456

## What is CVE-2026-44019?

CVE-2026-44019 is a high-severity path traversal vulnerability in docling-project docling-core, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Docling Core defines core data types and transformations for the document processing application Docling. In versions 2.5.0 and above, prior to 2.74.1, docling-core could allow local file:// image references and accepted inline data: content without a decoded-size limit. In applications that accept untrusted image references, this may allow access to local files readable by the process or excessive memory use from large inline payloads. This issue has been fixed in version 2.74.1.

Weakness: CWE-73 (External Control of File Name or Path), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-44019?

3 open source packages ship an affected version, including docling-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling-core` | PyPI | From 2.5.0 | 2.74.1 |
| `docling-core` | PyPI | From 2.5.0 | 2.74.1 |
| `docling-core` | PyPI | From 2.5.0 | 2.74.1 |

## How do I fix CVE-2026-44019?

Upgrade docling-core to 2.74.1 or later.

## Is CVE-2026-44019 being exploited?

There is no known exploitation of CVE-2026-44019 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44019 and fix it if it is affected.

What it is: CVE-2026-44019 is a high-severity path traversal vulnerability in docling-project docling-core, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44019 in the wild and no public exploit code.

Affected packages and fixed versions:
- docling-core (PyPI): affected from 2.5.0; fixed in 2.74.1
- docling-core (PyPI): affected from 2.5.0; fixed in 2.74.1
- docling-core (PyPI): affected from 2.5.0; fixed in 2.74.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44019/ (Markdown: https://insights.sbomify.com/CVE-2026-44019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44019
- OSV: https://osv.dev/vulnerability/CVE-2026-44019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44019/
Summaries are generated and may contain mistakes; the official description above is the record.
