{"answers":{"affected":"3 open source packages ship an affected version, including fluentd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44024 in the wild and no public exploit code.","fix":"Upgrade fluentd to 1.19.3 or later.","what":"CVE-2026-44024 is a critical path traversal vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44024 and fix it if it is affected.\n\nWhat it is: CVE-2026-44024 is a critical path traversal vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44024 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluentd (Bitnami): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44024/ (Markdown: https://insights.sbomify.com/CVE-2026-44024/index.md)","id":"CVE-2026-44024","markdown":"https://insights.sbomify.com/CVE-2026-44024/index.md","name":"CVE-2026-44024","record":{"aliases":["BIT-fluentd-2026-44024","CLEANSTART-2026-EN06234","GHSA-44hj-4m45-frj3","MINI-2f53-xj9m-qx8c","MINI-6mcw-c5gv-m95w","MINI-84xv-wqvw-869x","MINI-89g7-jhvm-rwgh","MINI-ffjp-qj8v-836m","MINI-g686-3h7j-rg57","MINI-mf8g-ppg9-g7xj","MINI-mhff-3v4v-5jh7","MINI-pf44-qxjg-2fr4","MINI-prmp-23xp-g9cw","MINI-q9mq-2vch-q7xr","MINI-r7mc-cxpq-cqgw","MINI-rp4g-qghm-v2m6","MINI-vhxj-v58j-fmcg","MINI-wwqw-j6fx-6j82","MINI-xxwj-8485-4jv6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluentd log collector","requires_auth":"none","summary":"Attackers can achieve remote code execution by sending malicious tags to write arbitrary files via path traversal in Fluentd's file output plugin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fluentd","vendor":"fluentd"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd allows dynamically constructing file paths using the ${tag} placeholder, and insufficient validation of ${tag} in file configurations such as the path parameter of the out_file plugin allows attackers sending untrusted tags containing path traversal characters to write or overwrite arbitrary files and potentially achieve remote code execution. This issue is fixed in version 1.19.3.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":"2026-08-05","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-08-05T08:52:05Z","kind":"github_poc","ref":"https://github.com/0xdak/CVE-2026-44024_exploit","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","id":"CVE-2026-44024","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025"},"packages":[{"ecosystem":"Bitnami","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:bitnami/fluentd","source":"BIT-fluentd-2026-44024"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":null,"source":"GHSA-44hj-4m45-frj3"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:gem/fluentd","source":"GHSA-44hj-4m45-frj3"}],"prev":{"headline":"Docling Core has unsafe remote filename resolution","id":"CVE-2026-44023"},"products":["fluentd"],"published":"2026-07-08","related":[{"cvss_score":9.8,"headline":"Fluentd Escape Sequence Injection Vulnerability","id":"CVE-2017-10906","kev_date_added":null,"published":"2017-12-08"},{"cvss_score":8.8,"headline":"Fluent Fluentd and Fluent-ui use default password","id":"CVE-2020-21514","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":7.5,"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.5,"headline":"Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`","id":"CVE-2026-44160","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.2,"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.9,"headline":"ReDoS vulnerability in parser_apache2","id":"CVE-2021-41186","kev_date_added":null,"published":"2021-10-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["fluent"]},"summary":"Attackers can achieve remote code execution by sending malicious tags to write arbitrary files via path traversal in Fluentd's file output plugin.","url":"https://insights.sbomify.com/CVE-2026-44024/"}