# CVE-2026-44024: Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder

> Attackers can achieve remote code execution by sending malicious tags to write arbitrary files via path traversal in Fluentd's file output plugin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** BIT-fluentd-2026-44024, CLEANSTART-2026-EN06234, GHSA-44hj-4m45-frj3, MINI-2f53-xj9m-qx8c, MINI-6mcw-c5gv-m95w, MINI-84xv-wqvw-869x, MINI-89g7-jhvm-rwgh, MINI-ffjp-qj8v-836m, MINI-g686-3h7j-rg57, MINI-mf8g-ppg9-g7xj, MINI-mhff-3v4v-5jh7, MINI-pf44-qxjg-2fr4, MINI-prmp-23xp-g9cw, MINI-q9mq-2vch-q7xr, MINI-r7mc-cxpq-cqgw, MINI-rp4g-qghm-v2m6, MINI-vhxj-v58j-fmcg, MINI-wwqw-j6fx-6j82, MINI-xxwj-8485-4jv6

## What is CVE-2026-44024?

CVE-2026-44024 is a critical path traversal vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd allows dynamically constructing file paths using the ${tag} placeholder, and insufficient validation of ${tag} in file configurations such as the path parameter of the out_file plugin allows attackers sending untrusted tags containing path traversal characters to write or overwrite arbitrary files and potentially achieve remote code execution. This issue is fixed in version 1.19.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44024?

3 open source packages ship an affected version, including fluentd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluentd` | Bitnami | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |

Products: Fluentd Fluentd.

## How do I fix CVE-2026-44024?

Upgrade fluentd to 1.19.3 or later.

## Is CVE-2026-44024 being exploited?

There is no known exploitation of CVE-2026-44024 in the wild and no public exploit code.

Public exploit code:

- https://github.com/0xdak/CVE-2026-44024_exploit (github_poc): https://github.com/0xdak/CVE-2026-44024_exploit

## Other vulnerabilities in fluentd

- [CVE-2017-10906](https://insights.sbomify.com/CVE-2017-10906/): Fluentd Escape Sequence Injection Vulnerability (critical 9.8)
- [CVE-2020-21514](https://insights.sbomify.com/CVE-2020-21514/): Fluent Fluentd and Fluent-ui use default password (high 8.8)
- [CVE-2026-44025](https://insights.sbomify.com/CVE-2026-44025/): Fluentd: Exposure of Sensitive Information via Monitor Agent API (high 7.5)
- [CVE-2026-44160](https://insights.sbomify.com/CVE-2026-44160/): Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` (high 7.5)
- [CVE-2026-44161](https://insights.sbomify.com/CVE-2026-44161/): Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44024 and fix it if it is affected.

What it is: CVE-2026-44024 is a critical path traversal vulnerability in fluentd, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44024 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluentd (Bitnami): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44024/ (Markdown: https://insights.sbomify.com/CVE-2026-44024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44024
- OSV: https://osv.dev/vulnerability/CVE-2026-44024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44024/
Summaries are generated and may contain mistakes; the official description above is the record.
