{"answers":{"affected":"3 open source packages ship an affected version, including fluentd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44025 in the wild and no public exploit code.","fix":"Upgrade fluentd to 1.19.3 or later.","what":"CVE-2026-44025 is a high-severity vulnerability in fluentd, published on 8 Jul 2026."},"fix_prompt":"Check this codebase for CVE-2026-44025 and fix it if it is affected.\n\nWhat it is: CVE-2026-44025 is a high-severity vulnerability in fluentd, published on 8 Jul 2026. \nExploitation: There is no known exploitation of CVE-2026-44025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluentd (Bitnami): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n- fluentd (RubyGems): affected all versions; fixed in 1.19.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44025/ (Markdown: https://insights.sbomify.com/CVE-2026-44025/index.md)","id":"CVE-2026-44025","markdown":"https://insights.sbomify.com/CVE-2026-44025/index.md","name":"CVE-2026-44025","record":{"aliases":["BIT-fluentd-2026-44025","CLEANSTART-2026-NY24300","CLEANSTART-2026-RT77723","GHSA-pr7j-96cj-549h","MINI-34px-fvxg-6w89","MINI-4v7p-4r55-fjfm","MINI-4wmq-g5jw-44fq","MINI-5823-2499-68x6","MINI-5mxm-m7gf-2r8h","MINI-7vjx-mwhw-m8jj","MINI-899x-fvx7-f4p7","MINI-fqvc-6w2h-h52c","MINI-fvf5-xq4g-c865","MINI-jwww-5jgr-52vv","MINI-mfpq-jrvx-8prr","MINI-v226-4v4w-c684","MINI-vp2w-w6rq-64mp","MINI-wq93-x6jr-wfv4","MINI-xvh4-jvhw-wxcx"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"fluentd","vendor":"fluentd"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's Monitor Agent plugin in_monitor_agent exposes internal metrics and plugin information via a REST API, and responses from /api/plugins.json and related endpoints unintentionally include internal instance variables that may contain database passwords, API keys, or cloud credentials. This issue is fixed in version 1.19.3.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Memory corruption in Lix","id":"CVE-2026-44028"},"packages":[{"ecosystem":"Bitnami","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:bitnami/fluentd","source":"BIT-fluentd-2026-44025"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":null,"source":"GHSA-pr7j-96cj-549h"},{"ecosystem":"RubyGems","fixed":["1.19.3"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:gem/fluentd","source":"GHSA-pr7j-96cj-549h"}],"prev":{"headline":"Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","id":"CVE-2026-44024"},"products":["fluentd"],"published":"2026-07-08","related":[{"cvss_score":9.8,"headline":"Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","id":"CVE-2026-44024","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":9.8,"headline":"Fluentd Escape Sequence Injection Vulnerability","id":"CVE-2017-10906","kev_date_added":null,"published":"2017-12-08"},{"cvss_score":8.8,"headline":"Fluent Fluentd and Fluent-ui use default password","id":"CVE-2020-21514","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":7.5,"headline":"Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`","id":"CVE-2026-44160","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.2,"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.9,"headline":"ReDoS vulnerability in parser_apache2","id":"CVE-2021-41186","kev_date_added":null,"published":"2021-10-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["fluent"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-44025/"}