# CVE-2026-44025: Fluentd: Exposure of Sensitive Information via Monitor Agent API


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-fluentd-2026-44025, CLEANSTART-2026-NY24300, CLEANSTART-2026-RT77723, GHSA-pr7j-96cj-549h, MINI-34px-fvxg-6w89, MINI-4v7p-4r55-fjfm, MINI-4wmq-g5jw-44fq, MINI-5823-2499-68x6, MINI-5mxm-m7gf-2r8h, MINI-7vjx-mwhw-m8jj, MINI-899x-fvx7-f4p7, MINI-fqvc-6w2h-h52c, MINI-fvf5-xq4g-c865, MINI-jwww-5jgr-52vv, MINI-mfpq-jrvx-8prr, MINI-v226-4v4w-c684, MINI-vp2w-w6rq-64mp, MINI-wq93-x6jr-wfv4, MINI-xvh4-jvhw-wxcx

## What is CVE-2026-44025?

CVE-2026-44025 is a high-severity vulnerability in fluentd, published on 8 Jul 2026. 

### Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's Monitor Agent plugin in_monitor_agent exposes internal metrics and plugin information via a REST API, and responses from /api/plugins.json and related endpoints unintentionally include internal instance variables that may contain database passwords, API keys, or cloud credentials. This issue is fixed in version 1.19.3.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-44025?

3 open source packages ship an affected version, including fluentd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluentd` | Bitnami | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |
| `fluentd` | RubyGems | All versions | 1.19.3 |

Products: Fluentd Fluentd.

## How do I fix CVE-2026-44025?

Upgrade fluentd to 1.19.3 or later.

## Is CVE-2026-44025 being exploited?

There is no known exploitation of CVE-2026-44025 in the wild and no public exploit code.

## Other vulnerabilities in fluentd

- [CVE-2026-44024](https://insights.sbomify.com/CVE-2026-44024/): Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder (critical 9.8)
- [CVE-2017-10906](https://insights.sbomify.com/CVE-2017-10906/): Fluentd Escape Sequence Injection Vulnerability (critical 9.8)
- [CVE-2020-21514](https://insights.sbomify.com/CVE-2020-21514/): Fluent Fluentd and Fluent-ui use default password (high 8.8)
- [CVE-2026-44160](https://insights.sbomify.com/CVE-2026-44160/): Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` (high 7.5)
- [CVE-2026-44161](https://insights.sbomify.com/CVE-2026-44161/): Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44025 and fix it if it is affected.

What it is: CVE-2026-44025 is a high-severity vulnerability in fluentd, published on 8 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-44025 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluentd (Bitnami): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3
- fluentd (RubyGems): affected all versions; fixed in 1.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44025/ (Markdown: https://insights.sbomify.com/CVE-2026-44025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44025
- OSV: https://osv.dev/vulnerability/CVE-2026-44025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44025/
Summaries are generated and may contain mistakes; the official description above is the record.
