CVE-2026-44028 Memory corruption in Lix
Unbounded recursion in the NAR parser allows stack overflow and potential arbitrary code execution as root via the Nix daemon.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44028?
CVE-2026-44028 is a high-severity memory corruption vulnerability in Lix, published on 5 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An issue was discovered in Nix before 2.34.7 and Lix before 2.95.2. Unbounded recursion in the NAR (Nix Archive) parser could lead to a stack-to-heap overflow when the parser is run on a coroutine stack. The stack is allocated without a guard page, which means that a stack overflow could overwrite memory on the heap and could allow arbitrary code execution as the Nix daemon (run as root in multi-user installations) if ASLR hardening is bypassed. This can be exploited by all users able to connect to the daemon (e.g., in Nix, this is configurable via the allowed-users setting, defaulting to all users). The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 for Nix (introduced in 2.24.4); and 2.95.2, 2.94.2, and 2.93.4 for Lix (introduced in 2.93.0).
Weakness: CWE-674
Which versions are affected by CVE-2026-44028?
Linux distribution packages (1)
nix openSUSE:Tumbleweed | All versions | 2.34.7-1.1 |
How do I fix CVE-2026-44028?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-44028 being exploited?
There is no known exploitation of CVE-2026-44028 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-44028, GHSA-jggj-j5fq-x969, GHSA-vh5x-56v6-4368, UBUNTU-CVE-2026-44028, openSUSE-SU-2026:10696-1.