{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-44028 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-44028 is a high-severity memory corruption vulnerability in Lix, published on 5 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44028 and fix it if it is affected.\n\nWhat it is: CVE-2026-44028 is a high-severity memory corruption vulnerability in Lix, published on 5 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44028 in the wild and no public exploit code.\n\nAffected product: Lix. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44028/ (Markdown: https://insights.sbomify.com/CVE-2026-44028/index.md)","id":"CVE-2026-44028","markdown":"https://insights.sbomify.com/CVE-2026-44028/index.md","name":"CVE-2026-44028","record":{"aliases":["DEBIAN-CVE-2026-44028","GHSA-jggj-j5fq-x969","GHSA-vh5x-56v6-4368","UBUNTU-CVE-2026-44028","openSUSE-SU-2026:10696-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Nix package manager","requires_auth":"low_privilege","summary":"Unbounded recursion in the NAR parser allows stack overflow and potential arbitrary code execution as root via the Nix daemon.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"An issue was discovered in Nix before 2.34.7 and Lix before 2.95.2. Unbounded recursion in the NAR (Nix Archive) parser could lead to a stack-to-heap overflow when the parser is run on a coroutine stack. The stack is allocated without a guard page, which means that a stack overflow could overwrite memory on the heap and could allow arbitrary code execution as the Nix daemon (run as root in multi-user installations) if ASLR hardening is bypassed. This can be exploited by all users able to connect to the daemon (e.g., in Nix, this is configurable via the allowed-users setting, defaulting to all users). The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 for Nix (introduced in 2.24.4); and 2.95.2, 2.94.2, and 2.93.4 for Lix (introduced in 2.93.0).","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in Lix","id":"CVE-2026-44028","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":5,"next":{"headline":"Path traversal in Nix","id":"CVE-2026-44029"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.34.7-1.1"],"introduced":["0"],"last_affected":[],"package":"nix","purl":"pkg:rpm/opensuse/nix\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10696-1"}],"prev":{"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025"},"products":["Lix","Nix"],"published":"2026-05-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-09","vendors":["Lix Project","NixOS"]},"summary":"Unbounded recursion in the NAR parser allows stack overflow and potential arbitrary code execution as root via the Nix daemon.","url":"https://insights.sbomify.com/CVE-2026-44028/"}