# CVE-2026-44028: Memory corruption in Lix

> Unbounded recursion in the NAR parser allows stack overflow and potential arbitrary code execution as root via the Nix daemon.

- **Severity:** High 7.5 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 9 May 2026
- **Also known as:** DEBIAN-CVE-2026-44028, GHSA-jggj-j5fq-x969, GHSA-vh5x-56v6-4368, UBUNTU-CVE-2026-44028, openSUSE-SU-2026:10696-1

## What is CVE-2026-44028?

CVE-2026-44028 is a high-severity memory corruption vulnerability in Lix, published on 5 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in Nix before 2.34.7 and Lix before 2.95.2. Unbounded recursion in the NAR (Nix Archive) parser could lead to a stack-to-heap overflow when the parser is run on a coroutine stack. The stack is allocated without a guard page, which means that a stack overflow could overwrite memory on the heap and could allow arbitrary code execution as the Nix daemon (run as root in multi-user installations) if ASLR hardening is bypassed. This can be exploited by all users able to connect to the daemon (e.g., in Nix, this is configurable via the allowed-users setting, defaulting to all users). The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 for Nix (introduced in 2.24.4); and 2.95.2, 2.94.2, and 2.93.4 for Lix (introduced in 2.93.0).

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-44028?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nix` | openSUSE:Tumbleweed | All versions | 2.34.7-1.1 |

## How do I fix CVE-2026-44028?

Upgrade to a fixed version.

## Is CVE-2026-44028 being exploited?

There is no known exploitation of CVE-2026-44028 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44028 and fix it if it is affected.

What it is: CVE-2026-44028 is a high-severity memory corruption vulnerability in Lix, published on 5 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44028 in the wild and no public exploit code.

Affected product: Lix. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44028/ (Markdown: https://insights.sbomify.com/CVE-2026-44028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44028
- OSV: https://osv.dev/vulnerability/CVE-2026-44028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44028/
Summaries are generated and may contain mistakes; the official description above is the record.
