CVE-2026-44046 Apache APISIX: wolf-rbac plugin Identity Spoofing

Low 2.3 Published Updated

Attackers can spoof identity in logs and bypass IP-based access controls in Apache APISIX using the wolf-rbac plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44046?

CVE-2026-44046 is a low-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Use of Less Trusted Source vulnerability in Apache APISIX.

Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules. This issue affects Apache APISIX: from 1.2.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-348

Which versions are affected by CVE-2026-44046?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 1.2.03.17.0

Products include Apache Apisix.

How do I fix CVE-2026-44046?

Upgrade apisix to 3.17.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-44046 being exploited?

There is no known exploitation of CVE-2026-44046 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-44046, GHSA-pmhp-pr8x-258q, MINI-fh6h-24c5-88vm.

Is CVE-2026-44046 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free