CVE-2026-44087 Apache APISIX: Openid-connect plugin Identity Header Spoofing

Medium 5.3 Published Updated

Attackers can spoof identity headers in the openid-connect plugin to gain unauthorized access to protected resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44087?

CVE-2026-44087 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX.

The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-345

Which versions are affected by CVE-2026-44087?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 2.3.03.17.0

Products include Apache Apisix.

How do I fix CVE-2026-44087?

Upgrade apisix to 3.17.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-44087 being exploited?

There is no known exploitation of CVE-2026-44087 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-44087, GHSA-4v22-j8v6-qgvh, MINI-w79m-fhv4-v736.

Is CVE-2026-44087 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free