# CVE-2026-44087: Apache APISIX: Openid-connect plugin Identity Header Spoofing

> Attackers can spoof identity headers in the openid-connect plugin to gain unauthorized access to protected resources.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BIT-apisix-2026-44087, GHSA-4v22-j8v6-qgvh, MINI-w79m-fhv4-v736

## What is CVE-2026-44087?

CVE-2026-44087 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX.

The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources.
This issue affects Apache APISIX: from 2.3 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-44087?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 2.3.0 | 3.17.0 |

Products: Apache Apisix.

## How do I fix CVE-2026-44087?

Upgrade apisix to 3.17.0 or later.

## Is CVE-2026-44087 being exploited?

There is no known exploitation of CVE-2026-44087 in the wild and no public exploit code.

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44087 and fix it if it is affected.

What it is: CVE-2026-44087 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44087 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 2.3.0; fixed in 3.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44087/ (Markdown: https://insights.sbomify.com/CVE-2026-44087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44087
- OSV: https://osv.dev/vulnerability/CVE-2026-44087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44087/
Summaries are generated and may contain mistakes; the official description above is the record.
